Snow Plowing Forum banner
1 - 4 of 4 Posts

· Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hello,
My name is hartz and I am new to the forum. I have a Blizzard 680LT that I bought new in 2003.
It has moved a lot of snow since I am on the south shore of Lake Superior. The pump motor Failed on me. In my search for another pump, while the original, has a number of 60282, all the replacements I have found are 60283. Does any one know if these two motors are interchangeable?
Thanks for any help I can get.
hartz
 

· Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
After Googling 3(2004,2012 and 2014) owners manuals, I saw that the 60282 number in the 2004 manual included the pump and in the 2012 and 2014 manuals 60283 number is the motor only. At any rate, I decided to check with the local rebuilding house and they said they could sell me a replacement made in China for a good price. They opened up the original old motor and said it was higher quality and to rebuild it would be 1/3 the cost of the Chinese copy. They rebuilt it and it works fine. Thanks for the reply
 

· Registered
Joined
·
1,272 Posts
After Googling 3(2004,2012 and 2014) owners manuals, I saw that the 60282 number in the 2004 manual included the pump and in the 2012 and 2014 manuals 60283 number is the motor only. At any rate, I decided to check with the local rebuilding house and they said they could sell me a replacement made in China for a good price. They opened up the original old motor and said it was higher quality and to rebuild it would be 1/3 the cost of the Chinese copy. They rebuilt it and it works fine. Thanks for the reply
Good deal, glad your back up and running.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top