1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

4x4 will not engage

Discussion in 'Truck & Equipment Repair' started by 04f350powerv-xt, Nov 22, 2008.

  1. 04f350powerv-xt

    04f350powerv-xt Senior Member
    Messages: 125

    I had to go plowing the other night to do some clean-up to find out i had no 4x4...that was fun. So i got it looked at put 2 new hub locks in to the sweet tune of $540 each, still no 4x4 so my mechanic did some troubleshooting and told me my vacum solenoid was not working, so i put a new one in still no 4x4. My truck has shift-on-the-fly 4x4 i can't engage into 4x4 with the switch in the cab but i can manually lock the hubs to get 4x4. I know my mechanic pulled up some codes on the trucks computer, he said they may have to be cleared before the solenoid will work, but said it should work fine without clearing them. I don't think clearing the code's will make any difference so....any ideas?
  2. davespark

    davespark Junior Member
    from MN-WI
    Messages: 25

    ...Your heater wouldn't happen to only blow in defrost, would it? It sounds like you might have a vacuum leak. There's an O-ring in the hubs that's a common fail point, I wonder if they changed that when the new hubs were put in?

    I replaced my hubs with Warn manual hubs and plugged the vacuum line, I'm done with the vacu-suck hubs personally.

  3. hydro_37

    hydro_37 PlowSite Veteran
    from iowa
    Messages: 3,790

    Pull the vacuum lines at the wheel and put a vacuum guage on it and then turn the in cab switch. You should see the guage move and hold pressure.