1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

1998 chevy 4x4 push button

Discussion in 'Chevy Trucks' started by racer47, Nov 3, 2011.

  1. racer47

    racer47 Senior Member
    Messages: 381

    its got 4l80trans push button to go from 2 wheel to 4 hi or lo i changed switch and didn't do anything for it got new actuwater for front end still same had guy look at it he said replace control module under dash no getting any power to front actuator its mp1 transfer case it was fine till i had to go through 3 ft water , i no but had to go to Ohio state James cancer hospital to do test for kidney operation it come out after i went through water drove 60 miles to hospital 60 miles home lock back in went back through then unlocked drove 1 mile home .truck set unless pulling boat or plowing. now it wont engage light just flashes then go out i had guy look at it he said control module was bad no power to front actuator has mp1 transfer case gm part can get for 273.68 part #15025394 gm dealer said i should let them do diagnostic for 89.00 buck first to find problem is their anything else it could be any advise would be help full i got 3 other plow trucks but it the 1 i drive :help: i no theirs got to be some moter heads out their ussmileyflag
  2. BlizzardBeater

    BlizzardBeater Senior Member
    from Maine
    Messages: 420

    So if I understand this right, everything worked fine until you forded 3 feet of water. But now when you push the button for 4hi, it just blinks and nothing happens?
  3. kimber750

    kimber750 PlowSite Veteran
    Messages: 4,676

    My 98 blazer does this about once a year. I have been lucky in that pulling battery cable for a few minutes seems to fix it. Not sure how pulling battery cable fixes it, but I drove it so little I haven't looked into any further.
  4. racer47

    racer47 Senior Member
    Messages: 381

    worked fine till after i went throught water 2 time. water never got inside truck. now no power to front acuater and power to transfercase shift encoder moter for a second then nothing swithch just flashes then go out .
  5. racer47

    racer47 Senior Member
    Messages: 381

    put new transfer encoder shift moter in today fixed problem let it snow