1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

XV-2 question for Fisher tech support.

Discussion in 'Fisher Engineering Discussion' started by Buswell Forest, Nov 6, 2014.

  1. Buswell Forest

    Buswell Forest PlowSite.com Addict
    from NH
    Messages: 1,668

    Just brought my XV-2 home. Left side moves much faster than the right - in both directions.

    Why?

    My XV-1 does this too, but not nearly as pronounced.
     
  2. Stroke_this

    Stroke_this Member
    from Tughill
    Messages: 33

    In for info. Mine seems to be more noticeable this year when I put it on.
     
  3. nepatsfan

    nepatsfan Senior Member
    Messages: 727

    same here. when you scoop it's probably a 2 second delay before the right side stops
     
  4. jimbo64

    jimbo64 Senior Member
    Messages: 194

    Happened to me as well. Turned out to be a broken o ring and I didn't notice it was leaking fluid at first because it was in the middle of the night and it was such a small leak .Happened again this summer when I moved it from my yard into the garage , same thing..broken o ring.
     
  5. Buswell Forest

    Buswell Forest PlowSite.com Addict
    from NH
    Messages: 1,668

    Mine is new, as in I brought it home from the dealer today at 4pm. Should not be an o ring, I sure hope.
     
  6. jimbo64

    jimbo64 Senior Member
    Messages: 194

    It shouldn't but it happened to me the first month and my dealer said they've had a few problems with o rings. At least it was under warranty.
     
  7. gtmustang00

    gtmustang00 Senior Member
    from Berlin
    Messages: 747

    My XV2 is the same way. Bought new last year. My regular extreme v's are the same way. Always have been.
     
  8. Buswell Forest

    Buswell Forest PlowSite.com Addict
    from NH
    Messages: 1,668

    It is aggravating.
     
  9. Antlerart06

    Antlerart06 PlowSite Veteran
    Messages: 3,437

    My 09 MVP came with a bad valve on the lift It wouldn't holds its self up would bleed off I ran it till spring time when I had free time to take it to a dealer for warranty work

    Things happens with anything and Yes its very aggravating
     
  10. jimbo64

    jimbo64 Senior Member
    Messages: 194

    Did you return it to your dealer? It must be hard living with a new plow that doesn't function right.
     
  11. Buswell Forest

    Buswell Forest PlowSite.com Addict
    from NH
    Messages: 1,668

    The plow works fine, just need to wait that extra second and a half for the right wing to match the left.
    And that 1.5 seconds seems like 4 minutes. I just want know WHY it is like that, and why Fisher can not produce a plow that functions in a seamless and fluid fashion.
    And, can this be addressed and made to work like that. Not to put too fine a point on it, but $6,000 is what I spent on this plow with the deflectors on it. For that money, I want it to work "right".
     
  12. jimbo64

    jimbo64 Senior Member
    Messages: 194

    I would take it back to the dealer. It's a new plow and all functions should work properly....all mine do.
    Mine acted just like yours when I had the o ring problem and it didn't lose very much fluid before it started acting up. Could it be a little low on hyd.fluid ?
     
  13. Buswell Forest

    Buswell Forest PlowSite.com Addict
    from NH
    Messages: 1,668

    It may be low, I need to check. Dealer said it was normal. Shocker.
     
  14. Antlerart06

    Antlerart06 PlowSite Veteran
    Messages: 3,437

    I know what is wrong the pump is mounted wrong :dizzy:
     
  15. JustJeff

    JustJeff 2000 Club Member
    Messages: 2,023

    Mind did that after a few months of use. Came to find out the packing was bad on one of the angle cylinders. Had it replaced under warranty.
     
  16. cdmckane

    cdmckane Member
    Messages: 39

    My new XV does this as well, just not as pronounced. It's probably a second before the right side gets to full scoop after the left.
     
  17. Buswell Forest

    Buswell Forest PlowSite.com Addict
    from NH
    Messages: 1,668

    [​IMG]
     
  18. Buswell Forest

    Buswell Forest PlowSite.com Addict
    from NH
    Messages: 1,668

    This one is making an odd noise that my xv1 never made, like it binds or struggles...not impressed. Going to take it back.
     
  19. RONK

    RONK Senior Member
    from NJ
    Messages: 126

    Do you trust your dealer?
     
  20. Buswell Forest

    Buswell Forest PlowSite.com Addict
    from NH
    Messages: 1,668

    The customer service lacks. But the mechanics seem capable. Still, they sent it out like this.....