1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Xtreme v won't move, just clicks

Discussion in 'Truck & Equipment Repair' started by quadboy1793, Nov 19, 2014.

  1. quadboy1793

    quadboy1793 Junior Member
    Messages: 5

    Hey guys I am looking for a little help:

    I have 8' 6" Xtremev MM2 on a 2013 GMC2500 that will be going into it's 3rd season. When i hooked it up the contoller would just blink red so i cleaned the connections and it stays the solid red but the plow won't do anything, i hit the up button and it just clicks. So i changed the solenoid on the back of the plow but that didn't make any difference. I put the plow on another truck and it worked great so i determined it is truck side, any ideas what it could be tho?

    Thanks
     
  2. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,975

    Ck the power going to the solenoid
     
  3. pats plowing

    pats plowing Senior Member
    Messages: 281

    power cable off truck or isolation module swap parts with the working truck to determine which is failing
     
  4. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,975

    So the plow works with another trk
    Your set up just clicks
    So, I'm saying Ck for power to to solenoid, and then to the motor. Don't necessarily swap parts yet, see what's wrong first
     
  5. quadboy1793

    quadboy1793 Junior Member
    Messages: 5

    I swapped the module. That wasn't the problem. Tomorrow when I get to the shop I am going to try the cables. Thanks for suggestions so far!
     
  6. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,975

    So you tried your plow on another trk, what about your trk and another plow?