1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

xtreme v problems

Discussion in 'Fisher Engineering Discussion' started by iowadmaxss, Feb 25, 2014.

  1. iowadmaxss

    iowadmaxss Junior Member
    Messages: 14

    last night as i was almost done with my first commercial property my blade gave me fits, i would hit the button to raise and ALL my lights started flashing along with a clicking noise in the pump, it continued even when i released the raise button..any suggestions?
  2. 1olddogtwo

    1olddogtwo PlowSite Fanatic
    Messages: 11,395

    Grounds are the biggest problems with plows.
  3. Brian Young

    Brian Young PlowSite Veteran
    Messages: 3,382

    These plows are so involved any more, who knows. I would just check the basics, if ya don't find anything your just going to have to go to the dealer.
  4. kimber750

    kimber750 PlowSite Veteran
    Messages: 3,179

    Sounds like something is shorting out. Pull covers off the pump and inspect. Pay close attention to the two main power cables. This plow has the solenoid under those covers.
  5. iowadmaxss

    iowadmaxss Junior Member
    Messages: 14

    i found the problem.. the positive wire was barely held on.the nut was gone from when the dealer installed it. working good now
  6. kimber750

    kimber750 PlowSite Veteran
    Messages: 3,179

    If this was down on the plow it is DD's fault since these plow sides come wired from factory. If up on truck it is installer's fault. If it has been a few years since install it is your fault for not checking connections. :drinkup:

    Every year I go over all connections, remove and grease all the pins, change fluid and filter, and check all the bolts.
  7. Buswell Forest

    Buswell Forest PlowSite.com Addict
    from NH
    Messages: 1,668

    I had a set screw on the valve body come loose on me, leaked like a sieve. 20 seconds with a hex head.