1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

xtream V problem

Discussion in 'Fisher Engineering Discussion' started by A&J Landscaping, Jan 18, 2013.

  1. A&J Landscaping

    A&J Landscaping Senior Member
    Messages: 162

    Hi the 9,6 xtream v on my 09 f-550 has never gave me any troble till the other night. When your plowing and go to use the controler up down side by side scoop or vee the power light starts to blink and it wont move at all. If i get out of the truck and giggle the wires comming of the modula on the truck for the plow the it stops blinking and it works for one pass and then happens agen. So i checked all of the plugs and conections and nothing was lose or broken. Im not sure if its the contorler or not any help would be grate thanks.
     
  2. nealybird

    nealybird Senior Member
    Messages: 716

    it blinks when it's having trouble communicating with the plow module out on the power unit. If wiggling the grill connector seems to make a difference, then that's probably where the problem is.
     
  3. unhcp

    unhcp PlowSite.com Addict
    Messages: 1,243

    i wonder if he his power cable is bad or worn out?
     
  4. A&J Landscaping

    A&J Landscaping Senior Member
    Messages: 162

    We found a broken wire thanks for the help