1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

xp810 power issue

Discussion in 'SnowDogg Snow Plows' started by hayisforhorses, Nov 26, 2014.

  1. hayisforhorses

    hayisforhorses Junior Member
    from canada
    Messages: 29

    plow worked fine yesterday hooked on tonight plow lifted and wings went part way out then quit lowered plow then it would not raise there is no noise when attempting to raise from the motor any ideas? snowing like a bugger out right now
     
  2. djagusch

    djagusch 2000 Club Member
    from mn
    Messages: 2,071

    Jump the solinoid to see if that went out and is a common/simple repla cement part. If it doesn't run jumping the posts together check for pwr there then at the motor itself. It would mean the motor isn't getting pwr or its bad.
     
  3. hayisforhorses

    hayisforhorses Junior Member
    from canada
    Messages: 29

    Heading out to give it a try
     
  4. hayisforhorses

    hayisforhorses Junior Member
    from canada
    Messages: 29

    Crossed solenoid over no sign of life no power at motor. Short chain it off to dealer
     
  5. djagusch

    djagusch 2000 Club Member
    from mn
    Messages: 2,071

    If you don't have pwr meaning 12 volts at the solinoid it's easy to trace the issue as it goes to the battery.

    If your saying you have 12 bolts to the plow motor and nothing happens the motor has issues.
     
  6. hayisforhorses

    hayisforhorses Junior Member
    from canada
    Messages: 29

    Shout out a big thanks to djagusch !! thanks man found a very loose connection