1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Wrong Parts?

Discussion in 'Fisher Engineering Discussion' started by RoseMan806, Jan 31, 2013.

  1. RoseMan806

    RoseMan806 Member
    Messages: 96

    MM1 Three plug. Notsure what year plow.
    I bought this plow used and noticed some parts that just didn't look right. The picture below shows the pin not going through all the way and every plow I've looked at so far has the pin going all the way through. Too short of pin?

    [​IMG]

    I dont think these adapters are needed. I purchased a spare hose and it seems like the hose should thread into the 45* fittings and the adapters are not needed.

    [​IMG]
     
  2. Snow Commandor

    Snow Commandor Senior Member
    from 07666
    Messages: 439

    I noticed the same thing on my minute mount with those pins. I was able to just tap them with a hammer to get them to go all the way through. The only problem is there's no cotter pin to stop them from sliding back out. Just flawed design if u ask me? As far as the fittings go, I would start with all new 45 degree swivel fittings (yours look to be pretty old & rusty). U should be able to get them with a female so the male end of the hose threads in directly without any adapter. Do u have any pics of the spare hose u bought?
     
  3. Snow Commandor

    Snow Commandor Senior Member
    from 07666
    Messages: 439

    I don't really see anything in your pics that resemble adapters of any kind. The fitting on the right accually looks to be ok. I would change the 2 fittings on the left, given that they don't look to healthy. Otherwhise there's really nothing wrong with those hose connections @ the pump.