1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Wont start

Discussion in 'Chevy Trucks' started by RBRONKEMA GHTFD, Mar 25, 2008.

  1. RBRONKEMA GHTFD

    RBRONKEMA GHTFD 2000 Club Member
    Messages: 2,592

    Hey guys a buddy of mine just got a 05 trailblazer on thursday, and he brought it over today, and we were going to hook up a headlight flasher to it, as he is on a fire dept. and we went to move it out of the garage for a sec, and it wouldn't turn over. Thinking it was the battery we tried to jump it, and still nothing. Now we never accually hooked anything up to the truck, but we got all the wires ran to where they need to be, but no power was run to anything. The car wont even click, or even try to turn over. The radio works just fine, and everything else does too. I went thru and checked every fuse under the hood, and every fuse under the rear seat. (those are the keyed ign. ones.) Not a fuse was popped. I can't figure it out. Any thoughts?
     
  2. yzf1000_rider

    yzf1000_rider Senior Member
    Messages: 147

    try moving shifter around while trying too crank engine. possibly the neutral safety switch.
     
  3. RBRONKEMA GHTFD

    RBRONKEMA GHTFD 2000 Club Member
    Messages: 2,592

    Thats kinda what were thinking but were not sure. I can jump the 2 posts on the starter and it will turnover but it wont engage on the flywheel. We towed it to the dealer around 8 ish my time, and they open at 8 so were hopin to hear something back from them in the morning. Any other thoughts on what it might be? Oh I will also add, that when you turn the key forward to the "ON" position none of the indicators are on to show what gear it is in. Thanks for any and all help guys.
     
  4. kashman

    kashman PlowSite.com Addict
    Messages: 1,070

    bad accessory wire
     
  5. RBRONKEMA GHTFD

    RBRONKEMA GHTFD 2000 Club Member
    Messages: 2,592

    What wire would that be? I guess I am not getting what you mean?
     
  6. kashman

    kashman PlowSite.com Addict
    Messages: 1,070

    most cars trucks now have 2 hot wires one for the starter and 1 for everything els but the acc wire has a post for it that gets crudded up and snaps.
     
  7. RBRONKEMA GHTFD

    RBRONKEMA GHTFD 2000 Club Member
    Messages: 2,592

    Yeah I see what your saying now. Although we checked over every wire on the car 2 or 3 times, and also every fuse was looked at 2 or 3 times aswell.
     
  8. kashman

    kashman PlowSite.com Addict
    Messages: 1,070

    i did the same thing on my ford f350 i checked my wires for a hr it wasnt all the way broke off just enough 2 F with me
     
  9. z400

    z400 Member
    Messages: 82

    you checked alot of wires..


    even the ones tucked up behind the dash and such?
     
  10. RBRONKEMA GHTFD

    RBRONKEMA GHTFD 2000 Club Member
    Messages: 2,592

    Yup. We did.
     
  11. wirenut

    wirenut Senior Member
    from nh
    Messages: 508

    starter.....?
     
  12. RBRONKEMA GHTFD

    RBRONKEMA GHTFD 2000 Club Member
    Messages: 2,592

    Hey guys, we brought it to the dealers last night and they looked at it first thing this morning and it ended up being the fuel pump. And now that I think back to last night I can remember not hearing the fuel pump running when the key was turned on. My buddy said that when he bought it the dealer said that, that was something that needed to be looked at within sometime as it was going bad. Luckly it went now, and not out of warrenty. But its all good now and back out on the road.
     
  13. kashman

    kashman PlowSite.com Addict
    Messages: 1,070

    so how did you not have power if it was the fuel pump
     
  14. z400

    z400 Member
    Messages: 82

    yea i dont understand..

    if the fuel pump doesnt work.. the engine's starting components receive no power at all?


    i use to own a trailblazer, it had wiring and manifold issues
     
  15. RBRONKEMA GHTFD

    RBRONKEMA GHTFD 2000 Club Member
    Messages: 2,592

    Well apparently when the fuel pump went it blew the ignition fuse? Weather or not it is suppost to do so I am not sure. I think that it may run in the same harness or something so you don't burn your starter up. So if you are cranking on it and the pump is shot you don't burn that up or anything else in the motor. These newer trucks are so hard to figure out these days.