1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Wiring question

Discussion in 'Fisher Engineering Discussion' started by pconley, Jan 30, 2010.

  1. pconley

    pconley Junior Member
    from Maine
    Messages: 7

    I wondered if any one could help me with a wiring problem I'm having? I was changing a headlight on my MM2 and heard a slight sound like a short, and now my flashers & marker lights don't work on the plow. Plow is on 02 F-350. Thanks
     
  2. t.i.b

    t.i.b Senior Member
    Messages: 140

    did you check the fuses'? truck and plow? i'd start there.
     
  3. pconley

    pconley Junior Member
    from Maine
    Messages: 7

    I checked all truck fuses & found 1 fuse inside grill w/ plow wiring. Are there more plow fuse I haven't seen? Thanks.
     
  4. t.i.b

    t.i.b Senior Member
    Messages: 140

    mine has 2 in the plow harness both right next to each other.
     
  5. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    There's a 15 amp park/turn fuse right by the isolation module if it's a 4 port or a 10 amp in the same location if it's a 3 port. Plus a 10 amp control fuse in the same location on either one.
     
  6. pconley

    pconley Junior Member
    from Maine
    Messages: 7

    Thanks for the help, I'll Check these out tomorrow.
     
  7. pconley

    pconley Junior Member
    from Maine
    Messages: 7

    I found the other fuse, it was a 15 amp. Thanks for the info.