1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

wiring issue

Discussion in 'Strobe Lighting' started by trailmix, Nov 23, 2013.

  1. trailmix

    trailmix Junior Member
    Messages: 9

    I put 2 buyers led work lights on today ran the wiring and went to plug into the switch and nothing..not even my mini bar or hideaways are working now. I didnt change anything with the already installed lighting. Just unplugged the harness and stuff to take down the plastic piece to install the switch and plugged everything back in the right place.

    I tested the switch with a battery that was laying around and everything was working..so im thinking the power or ground or both, truck side, is messing up. In the attached picture, is there a fuse for the circled harness? if anyone can tell what it powers..an old buddy of mine spliced into it so im not sure what that harness is for

    wiring.jpg
     
  2. chuckraduenz

    chuckraduenz Senior Member
    Messages: 345

    looks to be for putting a beacon on the roof. from the plow upgrade option. there should be power and ground wires looped up in between the headliner and the roof.
     
  3. trailmix

    trailmix Junior Member
    Messages: 9

    Okay. Yeah there was already a factory switch in the panel. Fisher hooked the mini bar up to it..so that harness is solely for the roof light? Would there be a fuse for it?

    I'm just stumped because I get power to the factory switch (little indicator light comes on) butt the bar doesn't light up..
     
  4. fordtruck661

    fordtruck661 Senior Member
    from CT
    Messages: 404

    Use a test light and make sure that you are getting power to all your switches. If you are move from there.......See if power is leaving the switches when on. If you are... go to the light and make sure that you are getting power to the lights.
     
  5. chuckraduenz

    chuckraduenz Senior Member
    Messages: 345

    what yr model of truck?
     
  6. trailmix

    trailmix Junior Member
    Messages: 9

    It's a 2008 2500
     
  7. chuckraduenz

    chuckraduenz Senior Member
    Messages: 345

    if the light comes on id say there is power to the switch. id check to make shure theres power at the light first. then work back.
     
  8. Mr.Markus

    Mr.Markus PlowSite Fanatic
    Messages: 5,169

    Sounds like a fuse. Try your 30-Amp S/ROOF fuse #33 which is located in the Underhood Electrical Center. That's quite often the one used for the beacon light on the snow plow prep.
     
  9. trailmix

    trailmix Junior Member
    Messages: 9

    That was the culprit, thanks!
     
  10. Mr.Markus

    Mr.Markus PlowSite Fanatic
    Messages: 5,169

    Always my starting point where "no power" is concerned when wiring. Know what circuit you're on. Glad it was easy...
     
  11. chuckraduenz

    chuckraduenz Senior Member
    Messages: 345

    that's odd ida thought that if the switch indicator light came on the fuse was good.....
     
  12. Mr.Markus

    Mr.Markus PlowSite Fanatic
    Messages: 5,169

    When he asked "is there a fuse for the circled harness?" it was a tip off it hadn't been checked....