1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

wiring headahe!!!!!!!

Discussion in 'Fisher Engineering Discussion' started by nalegtx, Nov 18, 2010.

  1. nalegtx

    nalegtx Senior Member
    Messages: 138

    OK...so i hooked up my wiring harnesses and everything seems ok. all connections are tight and clean- all wiring is new.
    Truck is a 2006 ram 250 plow is a 3-plug 3 port module 8 HD. I have no power going to my controller. nothing turns on when i put the ignition to on/run. nada!!! I checked the pins in the controller harness and there is no 12v source present. I checked the solenoid. Found both big terminals have 12v and both small terminals are dead, both small terminals have continuity with ground.
    Can someone please give me some ideas/direction. What went wrong and where? Any help is great, thanx again everyone.:confused::eek:
  2. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    Did you verify your switched ignition source is good and supplying battery voltage all the way to the Iso? It's in port #3 socket C, wire should be labeled "ACC". Check it there. If it's a no go then either your keyed ignition wire placement isn't good or you have a fuse or two blown. Be sure to check them all, both in the plow harness and on the truck itself.

    Didn't miss the two single black/orange connections on the plow harness did you?

    It's usually something simple and overlooked.
  3. LON

    LON Senior Member
    Messages: 749

    which side of the solenoid did you put the power wire for the iso module?
  4. Arc Burn

    Arc Burn PlowSite.com Addict
    Messages: 1,138

  5. nalegtx

    nalegtx Senior Member
    Messages: 138

    if the plow is not hooked up do i still have 12 volts present at both big terminals on the solenoid? ****as far as those small wires, are you speaking of the individual connector-single wire - if so then i belive those are grounds and yes they are connected
  6. Arc Burn

    Arc Burn PlowSite.com Addict
    Messages: 1,138

    There should not be 12v at both sides of the solenoid untill you activate the controll, as well you would not see power at your controll untill the plow is completely plugged in
  7. nalegtx

    nalegtx Senior Member
    Messages: 138

    ok thanx...looks like i have something somewhere it doesn't............hopefully i can figure this out soon...........snows a comin'