1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Wire Problem

Discussion in 'Strobe Lighting' started by nrplowguy, Nov 4, 2009.

  1. nrplowguy

    nrplowguy Senior Member
    Messages: 130

    I just got my PS back the other day. When I hooked it up the lights flashed but at the same time there was a large arc and a loud snap when the strobe fired. I took out the light it was mounted in and found that right where the wires come out of the AMP connector the wires had rubbed and the sheathing had opened up exposing two wires. oh yeah and this is on the cable leading to the strobe not the lead coming from the strobe.

    So my ? is should I just wrap them up or go daown to radio shack and pick up some new pins and redo the connector?
     
  2. SafetyLighting

    SafetyLighting Senior Member
    Messages: 601

    How far from the pins is the exposure?
     
  3. Dissociative

    Dissociative 2000 Club Member
    Messages: 2,066

    i doubt you find the pins at the shack....

    and you can strip the wires and use butt connections if you tape them very well and it will be fine...not perfect as heat shrink over butt connections but it works....

    it's not a big deal.....chaffing happens all the time...
     
  4. nrplowguy

    nrplowguy Senior Member
    Messages: 130

    the rub spot is right next to the amp conn and by surprise the shack in town carries amp stuff