1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Who has personally installed a boss plow on a 2011+ FORD SUPERDUTY?

Discussion in 'Boss Plows Discussion' started by Ramairfreak98ss, Dec 3, 2014.

  1. Ramairfreak98ss

    Ramairfreak98ss PlowSite.com Addict
    Messages: 1,905

    I've installed and helped install probably a dozen boss plows by now, almost all on superduty trucks. Last year we put a new vxt on a 2011 F350. All is well except the headlights on the plow don't switch over. Never got it to work. I have an HID kit on the truck , but then all of our trucks do and their plows have headlights when you flip the boss switch to plow...

    Thats part of the problem, the other issue is once you switch over to boss headlights, and then back to the truck lights, the truck HIDs won't come back on. you need to actually turn the headlight switch from on or auto to OFF then back to auto or on. Sometimes you need to turn the truck fully off, and key out, so no ignition then they come back on.

    We're finishing up a 2014 F550 today so i'll know if that works or does the same as the 2011 F350. I fully understand how the headlight switch inside the truck works, and what needs to be connected under the hood for the harness, maybe its a stupid mistake, what should i check?

    Last year we also added the boss light additional $50 harness on but then quickly realized that its ONLY for the turn signals, which worked fine before hand anyway.

    anyone else run into issues or is it simply something i don't have hooked up right?
     
  2. Joks79

    Joks79 Junior Member
    Messages: 13

    I had no issues when I put my boss onto the 2012 f250 with the headlights. My turn signals on the plow don't work and I still never looked into the issue.
     
  3. Ray

    Ray PlowSite.com Veteran
    Messages: 153

    I installed the plow on my 2012 F250 and had no problem with the headlights, but I did have to add the additional relays for the turn signals to work.
     
  4. dcarr

    dcarr Member
    from ct
    Messages: 31

    i put one on my 13 f150 and it does the same thing with the headlights not always coming back on. the fords have a very sensitive electrical system. i tried hooking my led bar to my highbeam wire and it would kill the headlight. i had to use a relay for it to work. the headlight system on the ford doesnt seem to like any extra draw or spike in the amperage.
     
  5. weyland426

    weyland426 Junior Member
    from indiana
    Messages: 12

    I had a similar problem on my 08. I finally got a dealer to say to admit, such as dcarr noted, that the electronics are very sensative. The smart junction box (SJB) that controls such things as lights will "trip" when it senses either over-voltage/amperage or ground disturbance in an effort to protect the system. So, any auxiliary or ancillary circuits must be damn near perfectly installed to not cause a problem...no scotch locks and electrical tape connections :)