1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Where are you putting the plugs?

Discussion in 'Ram Trucks' started by nexcorp, Dec 2, 2009.

  1. nexcorp

    nexcorp Junior Member
    from midwest
    Messages: 10

    I feel like a damned idiot asking this. Im wiring the 06 3500 Laramie tomorrow for Western Ultra 3 port. I am trying to figure out where you guys with the 02 -07 Rams are putting the plugs since the grill raises with the hood, unlike other brands. I have the cummins 5.9, and thought Id save the $600 installation fee. I cant find any good pics or definitive instructions on the best place to put the plugs, and it seems the options are mostly on the drivers side of the radiator. I would actually pay for this advice. If somebody has a pic of the 3port wiring an an 06 cummins, that would be the chit.
     
  2. RepoMan207

    RepoMan207 PlowSite Fanatic
    from Maine
    Messages: 5,031

    My old 96 had them on top of the bumper between that an the hood. When we got it back from its install I put zip ties a little further back on the harness to keep them from falling backwards. Make sure to keep your light & control harness spaced together so you can plug them into one another when there not in use.
     
  3. sno commander

    sno commander PlowSite.com Addict
    from ct
    Messages: 1,061

    driver side right above the chrome bumper below the plastic heres a pic to help you out hope it helps:drinkup:
    i just tuck it behind the bumper it sits in there nice

    001.jpg
     
  4. provfirescott

    provfirescott Senior Member
    from Ma
    Messages: 101

    Same place here
     
  5. show-n-go

    show-n-go Senior Member
    Messages: 776

    I hae a western on a ford but i figured you would know this answer. Do i need to plug mine together when not in use? I just put it on and my lights work fine without doing this.
     
  6. nexcorp

    nexcorp Junior Member
    from midwest
    Messages: 10

    Thank you guys. I pretty much did the same as there really is no alternative. Its not bad either. Everything on my install worked the first time it tried it, which is wickedly awesome considering this was the first time I installed one. Took forever though.