1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

whelen edge 9000 repair?

Discussion in 'Strobe Lighting' started by bdbwtie1, Apr 22, 2010.

  1. bdbwtie1

    bdbwtie1 Junior Member
    Messages: 13

    I'm looking for insight on a light bar I just picked up. Its the four foot module with alley lights and take downs. Its all controlled of from a 5 switch box. Switches being strobes,front flash, rear flash, right alley,left alley and take down. Ok 6 lol. The stobe switch lights up all ambers. While the front and rear will do seperately. But the alley light switches and take downs only make a clicking sound in the bar but nothing happens. I did notice that when running the strobes and clicking on the alley lights the lighted toggel for the strobes will go out. I'm very new to this and don't know if this sounds like something simple to look at. Or if anyone knows of a place arounf grand rapids michigan that works on these?? Any help would be much appreciated!
     
  2. Pirsch

    Pirsch Senior Member
    Messages: 596

    sounds like you may have multiple problems...#1 the switch box. Good possibility of it only sending part power to the bar.... Loose wire connections in the bar from where the wires attach to the individual units. Please check all your ground wires. ALL OF THEM...You may have a ground problem. Probably the easiest thing you can fix.

    There are alot of people on here from Michigan and I'm sure they can help you out.

    Good Luck
     
  3. bdbwtie1

    bdbwtie1 Junior Member
    Messages: 13

    Thanks for the reply! The trck actually went to into a local shop who outfits all the local pd cars. Meanwhile I'm on vacation! So hopefully it will be something simple like that!
     
  4. Pirsch

    Pirsch Senior Member
    Messages: 596

    At least you didn't take it down to Pitt... You may have found a Crosby in your back seat! :laughing: