1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Whelen Edge 9000 Confusion

Discussion in 'Strobe Lighting' started by j&hsnowplowing, Feb 7, 2011.

  1. j&hsnowplowing

    j&hsnowplowing Junior Member
    Messages: 19

    Hopefully Ill be able to figure out this problem with your guys' help. I have a whelen edge 900 lightbar. Now i have combed whelens manuals online and my wiring is different then theirs. I have to cables coming from the bar. But one doesnt have just red and black in it. It has red, black, green, orange, and white. The other cable has the same but with another orange, brown, and blue. So cable 1 = red, black, white, orange, green. Cable 2 = Red, White, Black, Blue, Orange, Orange, Yellow, Green, Brown. When I touch the brown wire and black wire from the same cable. Brown to + and black to - it turns on two flashers. When i do the Red wire on + from cable 1 and the green, orange, and white from cable 1 on - it just clicks. When i go back to cable 2 and put yellow on + with black grounded it turns on the passenger alley takedown. Any help would be greatly appreciated on how to get this to turn on fully. Also i have a switch box on the way. I dont know if that will help me I just got it so i could, hopefully, wire my truck up.
  2. kitn1mcc

    kitn1mcc Senior Member
    Messages: 516

    some pics would help
  3. Rc2505

    Rc2505 PlowSite.com Addict
    Messages: 1,245

    Here is the easy way to solve your problem. If you call Wheelen directly, and give them the serial number off the underside of your bar, they will e-mail you the electrical diagram specificaly for your bar. I had to call them this fall, and got the exact diargram, and I was able to get everything working.