1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Whelen Crap

Discussion in 'Strobe Lighting' started by Broncslefty7, Nov 19, 2014.

  1. Broncslefty7

    Broncslefty7 Senior Member
    Messages: 563

    last week i bought a 20" mini justice bar with the magnetic mount, 4 90# magnets.................... driving down the road today and the thing flies off and smashes into a thousand little pieces. dealer put it on. Whelen says and i quote "Well sir, the magnet lights are not supposed to be used while the vehicle is in motion"............ i told them r u kidding me u have 360lbs of magnet force..... They say "sorry you should have read the manual"...................... Sorry i cant take it off when im driving your dealer HARDWIRED it...

    Cant believe this bull...

    o and when you order it they forget to tell you that, you only get the 4 corner lights. if you want the 4 middle lights its 159 per module...
    Last edited: Nov 19, 2014
  2. John_DeereGreen

    John_DeereGreen PlowSite.com Addict
    Messages: 1,719

    That sucks...I've had the old halogen rotators from like TSC move, but never fall off.

    We run all ShoMe class 1 mag mount bars, and they've never even moved, much less flown off the trucks.

    Was the top of the cab clean before it went on? We have rubber "feet" over the magnents to help protect the truck cabs, and they practiclly stick to the cab. No sliding at all.

    If they're not supposed to be used while it's in motion, why the hell do they put magnents on them? If you're sitting still you should be able to just set it on the roof and not worry!
  3. JeffNY

    JeffNY Senior Member
    Messages: 484

    I have 8 LIN4's, 6 out of 8 have moisture in them, and they weren't interested in replacing them.
  4. Broncslefty7

    Broncslefty7 Senior Member
    Messages: 563

    surface was clean, rubber suction caps where on. at 45 mpg the light legitimately flew off the truck and ripped the wire out of the housing.
  5. WIPensFan

    WIPensFan PlowSite Veteran
    Messages: 3,468

    Broncs, sorry to hear about that happening. I just can't believe the thing flew off at 45mph, something had to be wrong with the suction cups-magnets-or where you mounted it. I've got a Whelen low profile strobe on my truck, magnetic mount, I couldn't move that thing with my Stihl Magnum backpack blower. Are you sure you didn't hit a tree branch or low wire or something?? Or maybe something moved it and you didn't notice for a while and then it wasn't secured as well and then flew off?
    Again, not trying to piss you off, but something doesn't add up here.
  6. 1olddogtwo

    1olddogtwo PlowSite Fanatic
    Messages: 11,396

    2+2= huh here....something is not adding up
  7. Broncslefty7

    Broncslefty7 Senior Member
    Messages: 563

    ur rite something isnt adding up. an employee was driving the truck when it came off. i told him to go find it, its only a ten minute drive to where he went and back. its been 2 hours, havnt heard from him...... all the pawn shops says nothing has come in yet. Police report is filed.
  8. John_DeereGreen

    John_DeereGreen PlowSite.com Addict
    Messages: 1,719

    I'm not going to come out and question your employee's honesty, but can you confirm that he was only going 45 and nothing hit it?

    I'm not buying that it flew off running 45. Ours have been on trucks for many thousands of miles at 75-80 and haven't moved.
  9. Broncslefty7

    Broncslefty7 Senior Member
    Messages: 563

    ive driven the truck 90 the past few days on the highway and it has been fine. he was pulling a mini excavator to the dealer easy on and easy off the highway there's no low hanging branches. if there was they would have also hit the excavator.
  10. hellion

    hellion Member
    Messages: 52

    I've got the exact same light that was ran all last season back and forth on interstate. Never moved. However; I was careful not to have any part of the 4 magnet feet on any ribs or grooves. That was an expensive loss. Hope you can find the cause.
  11. Bossman 92

    Bossman 92 PlowSite.com Addict
    Messages: 1,768

    Good luck figuring this out and keep us posted.
  12. Broncslefty7

    Broncslefty7 Senior Member
    Messages: 563

    quote from whelen "we do not recommend you attach that permantly to your truck, the roof is too thin and will fall apart after a year or two." they dont recommend permanent install or magnets if the vehicle will be moving.... this is so aggravating
  13. Buswell Forest

    Buswell Forest PlowSite.com Addict
    from NH
    Messages: 1,668

    Whelen won't be getting any of my money anytime soon..
  14. Diesel Dan

    Diesel Dan Senior Member
    Messages: 218

    I got a mini light bar with dual rotators off of ebay for $65 that I've done 90 with on the roof and gone threw an automatic car wash (with blower drying) with never moved. I put it on my backhoe and put a $60 ebay low profile LED bar on my truck that blew off in the car wash, dangling by the cord, but still works. Hasn't moved an inch driving.
  15. GLS

    GLS Senior Member
    Messages: 248

    We have 8 lin4 and 8 linz6. Most all of them have moisture, some were sent back under warranty.

    Once they get moisture, the LEDs will start failing. Some of ours half work, some are dim, some don't flash (stay lit). I had one last year that was so bad it was blowing the fuse, had to unhook the dang thing.

    I would not recommend these to anyone.

    To the original post, sucks about the lightbar. I am mounting a mini-justice I used to have permanent mounted on a truck onto my skidloader. I ordered a set of 120# magnets, hopefully it stays put.

    Can't believe yours didn't come with the con3 modules, must not be standard anymore. They also don't tell you that the corner leds in the mini justice have 6 diodes, my full size towman justice bars have 9 diodes in each corner.
  16. Sooner

    Sooner Member
    Messages: 34

    I just ordered 6 Whelen Magnet mount lights for our rigs. Now I'm nervous...
  17. Brian Young

    Brian Young PlowSite Veteran
    Messages: 3,382

    Im kind of confused here. Your saying your employee said it came off and now is nowhere to be found or did you actually see it in a million pieces. We run Whelen Responders with the suction cup/magnet mounts and they don't move once on the trucks. Ive driven speeds of well over 75-85 with them on (no plow on) and they don't budge. Sorry man!
  18. Polarismalibu

    Polarismalibu PlowSite Fanatic
    Messages: 9,686

    That's a shame. I have a responder and it's never even moved at all. I have gone threw the wash with it and down the highway it's never moved
  19. Polarismalibu

    Polarismalibu PlowSite Fanatic
    Messages: 9,686

    I wouldn't worry. I think it's a freak thing that happened. Damn shame that it did
  20. M & MD Lawn

    M & MD Lawn Senior Member
    Messages: 361

    I have a Mini Century I bought last year mid season and I have the suction/mag combo mount. That thing does not move and I have driven 90 in high winds down the highway and its still there. It stays on year round and I go to the carwash atlas once a week, if not twice.

    I would never buy the magnet mount tho, those four little magnets looks like its going to fly off the truck