1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

What's up with my unimount

Discussion in 'Western Plows Discussion' started by The mayor, Jan 23, 2008.

  1. The mayor

    The mayor Senior Member
    Messages: 272

    I have a older unimount that is very well maintained. After about 6-8 hours of run time everything stops. The controller goes black(no lights or power) Sometimes when plowing, yesterday when going to a different account. I get it home park it and take out the other truck. When I go to work on it the next day everything works like nothing happened. Any clues?
     
  2. basher

    basher PlowSite Fanatic
    from 19707
    Messages: 8,992

    Bad battery in the truck?
     
  3. The mayor

    The mayor Senior Member
    Messages: 272

    The battery was fresh this fall. I am wondering if this could be a solenoid.
     
  4. wild bill

    wild bill PlowSite.com Addict
    Messages: 1,239

    intermitant

    i wonder if there is a problem with the circuit board in the joystick ,temperature related ,heats up enough and shut's down ,cool;s off then works.
     
  5. The mayor

    The mayor Senior Member
    Messages: 272

    I thought it was the joystick and switched it out with one that keep in the glove box. still dead.
     
  6. The mayor

    The mayor Senior Member
    Messages: 272

    Turned out to be a the connector that holds the fuse.
     
  7. GripTruk

    GripTruk Senior Member
    Messages: 374

    Thanks for the update, could help someone searching in the future.