1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Western wiring info.

Discussion in 'Western Plows Discussion' started by bigjeeping, Aug 16, 2006.

  1. bigjeeping

    bigjeeping Senior Member
    Messages: 676

    Does anyone know someone near Ann Arbor, MI that works on western plows? I need my wiring looked at b/c the lights will not stay on. I'm too impatient to work with electric stuff!
     
  2. Crash935

    Crash935 2000 Club Member
    Messages: 2,377

    Its probably something really easy,

    Not staying on - as in wont come on, comes on and goes off after awhile?

    Does this happen with low beams, high beams or both?

    Is this only happening on the truck (Yeah, i know, plows buried so i couldnt tell ya, thats okay)

    How many plugs coming out of the grill 2 or 3?
     
  3. bigjeeping

    bigjeeping Senior Member
    Messages: 676

    It has 2 plugs coming out of the grille.

    One is obviously the power, and the other has all the pins in it. I've tried cleaning them out with battery cleaner and putting that electric gel stuff in there.


    Here's what happens:

    When you initially hook up the plugs, the parking lights will work but no head lights. Then I have to raise/lower the plow a few times and eventually the head lights will turn on (if im lucky) from moving the plow around.

    While I'm plowing the lights will flicker on and off as I drop/raise the plow.

    Let me know what you think
     
  4. snowplowpro

    snowplowpro Senior Member
    from NJ
    Messages: 901

    check your plug wiggle it with lights on see if they go on by wiggling the plug if thats work then your plug is bad if not on the back of the pump is a little red plastic box with two screws pop that off see if the wires in side there are coroed or something or maybe loose. or take the lights apart and see if wires are loose in there something loose cause my did that .or change your solenoid




    1996 FORD f250 7.6 western proplow unimount
     
    Last edited: Aug 18, 2006