1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Western V Troubleshooting

Discussion in 'Residential Snow Removal' started by WesternV, Jan 6, 2010.

  1. WesternV

    WesternV Junior Member
    from PA
    Messages: 2

    Please help. I purchased an older truck that came with a Western V plow with an Isarmatic Mark III pump.

    I have a few problems:

    1. The cable from the joystick to the pump was stuck. I recently replaced that, and it moves much easier.

    2. The first time I try and raise the blade, I have to move the joystick right. That raises the blade. After a few times, I can move the joystick up to raise the blade.

    3. The angles are now stuck in the scoup position. With the cable being replaced, it moves the toggle switch outside the truck next to the pump. However it doesn't change the angles. The pump is making a noise, like it is getting a connection inside the joystick, it is just not move the blades.

    What else can I check.

    Thanks.
     
  2. WesternV

    WesternV Junior Member
    from PA
    Messages: 2

    Isarmatic Update

    Well I made an adjustment to the cable that angles the blades. Now the blades do angle when the plow is on the ground.

    When I lift the plow up, then the blades only go into a scoop position, and don't return to the V position.

    Any thoughts?