1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

western unimount too working slow

Discussion in 'Western Plows Discussion' started by RNR Services, Jan 1, 2013.

  1. RNR Services

    RNR Services Junior Member
    Messages: 19

    I changed my hydrolic oil according to specs and now it is way too slow. What did I do wrong?
     
  2. mishnick

    mishnick 2000 Club Member
    Messages: 2,243

    What did you put in it for replacement fluid? You need to use the blue plow fluid not auto trans fluid or anything else. The blue plow fluid is highly modified to maintain a stable viscosity at a very wide range of temperatures. Trans fluid normally gets warm because the trans gets hot so it thins out when the vehicle is running. The plow motor and hydraulic unit only run momentarely so they never get to warm up leaving the fluid too thick for speedy operation.

    Aside from this there may be other issues like dirt in the valves or frozen ice crystals restricting the fluid flow.
     
  3. Malakas82

    Malakas82 Member
    Messages: 36

    Check your filter...i had the same problem
     
  4. #1 plowtech

    #1 plowtech Senior Member
    Messages: 253

    If you pulled your pump out,
    there is the oring that seals the pump to the housing,
    if its not there, none to little pressure.

    Make sure you take the advice from previous post, they are all relevent to your problem.