1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

western unimount plow wont get power

Discussion in 'Truck & Equipment Repair' started by foxxracer278, Dec 13, 2010.

  1. foxxracer278

    foxxracer278 Junior Member
    Messages: 21

    i have a western 6.5 unimount .....its on a 97 jeep wrangler...... my lights all turn on but nothing else works. i cant get the plow control light to turn on and it wont do anything the plow is almost brand new and i am very lost....i have a brand new solinoid that i put on... i am getting power to the solinoid but not to the plow any ideas?????
     
  2. Davidl79

    Davidl79 Junior Member
    Messages: 15

    Check to see if the solinoid is getting a good ground. Might want to check all the fuses inline.
     
  3. basher

    basher PlowSite Fanatic
    from 19707
    Messages: 8,992

    Check to make sure you are getting power to the control. could the control power wire gotten knocked loose or maybe the fuse is blown?
     
  4. hitachiman 200

    hitachiman 200 Senior Member
    Messages: 262

    make sure the controller connector is tight and that the power source for the controller is good(fuse) like basher says. the controler is powered seperatly, usualy from the inside fuse block (radio or lighter) or tapped into a hot wire under the dash. also don't toss the soliniod you replaced sounds like that wasn't the prob
     
    Last edited: Dec 14, 2010
  5. Nasty-Z

    Nasty-Z Senior Member
    Messages: 370