1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Western Unimount plow problem

Discussion in 'Western Plows Discussion' started by apex809, Dec 11, 2010.

  1. apex809

    apex809 Junior Member
    from Boone
    Messages: 14

    Have a western unimount plow. The problem is when i raise it. It settles back to the ground in 5-10 mins. I have checked the fluid level its ok. What else can it be? Thanks
     
  2. JohnnyU

    JohnnyU 2000 Club Member
    Messages: 2,040

    Sounds to me like you'll need to disassemble, clean, and inspect your cartridge valves. It's likely the S1 (powered with the LOWER function), or S3 (powered with RAISE function) cartridge that is damaged or contaminated, causing the lift cylinder to leak down. If the plow angles and operates properly otherwise, I would probably suspect the S1 cartridge.

    http://library.westernplows.com/pdf/21936_120198.pdf
     
    Last edited: Dec 11, 2010
  3. twinman326

    twinman326 PlowSite.com Addict
    Messages: 1,683

    Or it can the "gland" nut on the lift piston might be a little loose, or the seals are going bad..Try tighten the nut a little first..
     
  4. brrybck

    brrybck Junior Member
    Messages: 8

    low on pressure

    have cable operated pump only had 600 psi bought new pump for it still only have 600 psi
     
  5. twinman326

    twinman326 PlowSite.com Addict
    Messages: 1,683

    Here is a pic of a test you should try. Your looking to test S2 valve (2 way).
    s2lower.jpg

    Make sure the valve spool. The valve might be sticking, or something might be inside the channel.. Do the test, and let us know what happen

    s2lower.jpg
     
    Last edited: Dec 12, 2010