1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Western Unimount mvp will not go up

Discussion in 'Western Plows Discussion' started by mikeitu7, Mar 6, 2014.

  1. mikeitu7

    mikeitu7 Senior Member
    from Palos
    Messages: 264

    On a older mvp Unimount the plow scoops, v, and goes down.. When I press to go up it goes into v any help?
     
  2. mishnick

    mishnick 2000 Club Member
    Messages: 2,243

    Sounds like an S2 valve is failing to open. But if that was the case the left blade would not respond properly. Trying to swing the whole blade left (like a straight blade) and trying to retract the left wing by itself would also fail. Could be just a broken or disconnected wire on the S2 coil, a bad coil, a bad valve or electrical failing to send power to the coil. The S2 valve cartridge is on the driver's side, pull the black cover off and you will see three valves. Verify that all three have both wires securely connected. S2 is closest to the truck and has a lite blue and a red wire connected to it. The red is common positive and should be hot all the time with the key on so that is easy to verify with a test light. The other side needs to be verified too but it's a little more dangerous. You need someone to press the up button while you hold a screw driver or something to the coil end to feel for magnetism. You could also put a test light on that side but it will light up until you hit the up button and then it should go out because the controller grounds out that side of the coil. Either way, if you verify there is current flowing through the coil then pull the cartridge and examine it. You can put the coil on it and jump 12 volts to it to see if it clicks. If not then just replace the valve.
     
  3. mikeitu7

    mikeitu7 Senior Member
    from Palos
    Messages: 264

    Got it thank changed the valve and coil. Had another power unit and changed both of them. Works fine now
     
  4. mishnick

    mishnick 2000 Club Member
    Messages: 2,243

    Perfect! that was easy....