1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Western Unimount lifts and turns slow. READ ON!

Discussion in 'Truck & Equipment Repair' started by rwblawncare, Feb 28, 2013.

  1. rwblawncare

    rwblawncare Junior Member
    from 53405
    Messages: 4

    Hello all,
    Here is my problem which started today . I have a Western Unimount plow hooked up to a 2011 GMC Sierra 2500 HD. Plow was working fine all season until today. When the plow is lifted over half way is slows down and when I turn it its slow as well. It also triggers a "Service Traction Control" in the info center on the truck. But when the plow is lifed less than half way up its fine and turns as it should without triggering the code. Anyone have any idea what is going on. I have owned the plow since it was 1 year old and change fluids yearly,have replced the motor and pump but all the valves are original and have never been replaced. Sounds to me there is something causing a short somewhere.
     
  2. snowplowpro

    snowplowpro Senior Member
    from NJ
    Messages: 901

    Sounds like there's air in the system or its low on fluid check fluid level make sure lift arm is all the way down. If there's air in the system make sure you crack the quill nut just a little bit and let air out. It will bubble when you first crack it open.
     
  3. snowplowpro

    snowplowpro Senior Member
    from NJ
    Messages: 901

    Oh your gonna have to refill it after that.
     
  4. rwblawncare

    rwblawncare Junior Member
    from 53405
    Messages: 4

    Fluid was just replaced when I broke a hose a few weeks ago. I dont think low fluid would trip a code in the trucks info center. I was thinking maybe a coil? We just recently had a very wet and heavy snow fall. Maybe water shorted the coil?
     
  5. racer47

    racer47 Senior Member
    Messages: 322

    sounds like ground or bad connection or moter takeing a dump
     
  6. rwblawncare

    rwblawncare Junior Member
    from 53405
    Messages: 4

    If its a bad ground or a bad motor how does the system know how far the blade is up? When I lift the blade 6" its fine and turns fast like its supposed to. But when the plow gets raised past 6" it slows and so does the turning and the traction control light comes on on the dash.It really struggles to turn and . I will take another look in the morning when it gets light out and dig into this more and let you guys know what I find.
     
  7. racer47

    racer47 Senior Member
    Messages: 322

    . go to western site, publication library, download mechanics guide and manual for you plow, should help troble shoot could be pump presser low, plug up sump filter .are you sure it is full of oil. i dont see it being valves or coils
     
  8. snowplowpro

    snowplowpro Senior Member
    from NJ
    Messages: 901

    Does the motor squeal when its raising like its got alot of strain on it.
     
  9. rwblawncare

    rwblawncare Junior Member
    from 53405
    Messages: 4

    just got home and looked. the extra lift chain was stuck on the positive post of the motor.DUH!
     
  10. racer47

    racer47 Senior Member
    Messages: 322

    :mechanic:good way to get new truck if its insured:laughing:glad you got it fixed better put battery on charger :drinkup::waving: