1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

western uni mount plow power issues

Discussion in 'Truck & Equipment Repair' started by wisejadon, Dec 5, 2013.

  1. wisejadon

    wisejadon Junior Member
    Messages: 2

    We have a uni mount plow to a 3/4 ton chevy truck and have lights but no power to controller to raise, lower, or pivot. We replaced module and still nothing (boy that was pricey) snow in forecast so starting to panic?!! Any clues? Thanks!!
    Jadon Wise (Crystal Clear Custom Services)
     
  2. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,983

    Uni's don't have module. I'm thinking you mean ultramount?
    Fist ck all 3 fuses. 1 underdash for the clicker
    2 underhood 1 is for the lights the other is for the ISO module.
    Are you trying this with the plow hooked up? It has to to even turn on the clicker
     
  3. wisejadon

    wisejadon Junior Member
    Messages: 2

    ok yes its a ultra that sounds right. I believe we've checked all fuses. We are running through the whole system now with a tester trying to find anything!
     
  4. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,983

    Ok. You are cking with the plow connected correct?
    Do you have pwr at all the fuses?