1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

western ultra mount wont move......!!!!

Discussion in 'Western Plows Discussion' started by c&i concrete, Dec 11, 2012.

  1. c&i concrete

    c&i concrete Member
    Messages: 39

    i just installed a western ultra mount on one of my f-150s and the plow wont move.. the selinoid that the harness go to wont click... but when trying to move the plow the seinoid on the plow clicks.....i took one of my other trucks and hooked it up to the plow and it works fine.... im at a halt right now and need some help thanks...
  2. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,743

    ok,,,you say the solenoid wont click,,,but then you say it does??
    with the plow hooked up, does the controller turn on? backlite come on or the red, or green light come on?
  3. cubicinches

    cubicinches PlowSite.com Addict
    Messages: 1,412

    If the plow functions normally on another truck, I'd start with the battery relay on the truck in question. Use a test light to make sure that the large terminal on the relay which is connected directly to the battery is indeed hot. Then test for power at the opposite large terminal (the one that goes to the plow battery cable) while the control is activated to lift or angle. If no power at that terminal, check for power at one or the other of the small terminals on the relay when the control is activated. If you have power at one of the small terminals, but no power going out to the plow, then the relay is bad. If you get no power to either of the small terminals on the relay, then you have a wiring or control issue. If you do get power on the outgoing side of the relay, but the plow won't operate, then the truck side cable going to the plow likely has an issue.