1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Western Ultra-Mount Issue, need

Discussion in 'Western Plows Discussion' started by gd8boltman, Nov 19, 2007.

  1. gd8boltman

    gd8boltman Senior Member
    Messages: 326

    advice please. Used plow 03' newly installed on a 04' 2500 Suburban. Filled pump, any button on the joystick made it go to the pass. side (right) . Now it just makes noise and does not move in any direction, pulled motor, cleaned base and filter, were not too dirty, the odd thing is you can pull up and down on the lift ram willingly without much effort. I would appreciate any advice.

    Thanks
     
  2. StathemLawncare

    StathemLawncare Member
    Messages: 37

    Was pump completly drained if so it take alot of fluid to prime.Something like two or three quarts.
     
  3. gd8boltman

    gd8boltman Senior Member
    Messages: 326

    Thanks for your help

    I have filled sveral times
     
  4. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    Your S3 valve isn't opening...it needs the S3 to raise or angle left.
    To test the S3 valve, remove the plastic cover on the rear of the pump unit. You'll see the 3coil/valve assemblies..
    The S3 is the one with the light blue wire, check the coil for magnetism with a wrench or screw driver while a helper holds the controller in either the left or raise function (Be careful of blade movement!)
    If it doesn't have magnetism, recheck it with a test light to see if the light blue wire has power. (also check the ground wire on the coil too).

    If the coil does have magnetism..pull it off and then remove the valve and push in on the end of it with a small screw driver to see if the spool inside will move..
    If it won't, replace the valve..
     
  5. gd8boltman

    gd8boltman Senior Member
    Messages: 326

    Thanks for your help, I downloaded

    the Western manual, and after testing, it turned out to be the controller. I appreciate your advice.

    Thanks,