1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

western tornado spinner question

Discussion in 'Ice Management' started by mikeyt4e, Mar 21, 2015.

  1. mikeyt4e

    mikeyt4e Junior Member
    Messages: 9

    When i turn on my western tornado at first the spinner doesn't throw the salt as far as usually does on the max spinner setting. But after say 10-20 secs it starts throwing it like normal of the top setting. What could this be ?
  2. Mr.Markus

    Mr.Markus PlowSite Fanatic
    Messages: 5,108

    Old or new tornado...

    My first gen runs off a belt, if that belt gets wet it slips. You have to keep the cover on and make sure you don't hit it when lubricating the chain and sprockets.
  3. mikeyt4e

    mikeyt4e Junior Member
    Messages: 9

    new tornado.. yeah theres a belt maybe when i sprayed it with white lithium .. should i purchase a new belt or just clean it? thanks i appreciate your response
  4. Mr.Markus

    Mr.Markus PlowSite Fanatic
    Messages: 5,108

    I would just clean it, never hurts to have a spare belt behind the seat either.
  5. procuts0103

    procuts0103 Senior Member
    Messages: 788

    New tornado doesn't have a belt... you have the old one
  6. Hysert

    Hysert PlowSite.com Addict
    Messages: 1,209

    Its a cog belt!!! Wont matter if its oiled or wet as its running on a toothed pulley... sounds to me like voltage issue? Mite be the brushes in the motor! Could use a rewind but would get another opinon... when you hit blast both conveyor and spinner run at max...

    How are the bearings top and bottom???