1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

western tornado salter issue

Discussion in 'Truck & Equipment Repair' started by PaulW, Jan 4, 2014.

  1. PaulW

    PaulW Junior Member
    from Langley
    Messages: 2

    Just thought I would throw this out there. Have a 2yrd tornado, I always try the unit out before heading out, so there is no surprises when getting to our location. Unit worked fine , except for the common issue of the overloading beep of the conveyer motor, that we fix by spinning the drive motor chain a few revolutions, it frees up the conveyer and things work fine after that. Tonight unit worked before leaving our yard first sitecontroler turns off when start button is pressed , looked everything over , have good power controller has to be unplugged a few times to get it to light up , press the start button the lite up controller goes off, a few times it beeped with the red light in a single pulse order. Two yrs ago my Snowex 8500 did kind of the same thing worked fine then just one long beep everything worked fine when applying direct power to the spinner and auger , but didn't want to take the chance on buying a new $1000 controller to find that isn't the issue. So the snowex was shelved and put on a future to figure out and fix list. Hopping this Tornado doesn't have to be shelved for the season.
     
  2. PaulW

    PaulW Junior Member
    from Langley
    Messages: 2

    Problem fixed , had a second tornado in storage and just started trouble shooting using parts of it, to narrow down the issue. Ended up finding a bad ground under the hood.