1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Western tornado salt spreader :(

Discussion in 'Truck & Equipment Repair' started by jnelsonsnow, Dec 29, 2015.

  1. jnelsonsnow

    jnelsonsnow Junior Member
    Messages: 3

    A freind bought this used....my problem is how do I trouble shoot the control moulde. I can not afford to just go buy a new one.
     
  2. Philbilly2

    Philbilly2 2000 Club Member
    Messages: 2,609

    What is it doing/ not doing that you need to trouble shoot?
     
  3. jnelsonsnow

    jnelsonsnow Junior Member
    Messages: 3

    Brand new cab controls....convayer works fine fine...all speeds...but I can not get the spinner to come on.
     
  4. Philbilly2

    Philbilly2 2000 Club Member
    Messages: 2,609

    Have you checked for voltage at the spinner motor already?
     
  5. jnelsonsnow

    jnelsonsnow Junior Member
    Messages: 3

    Yes...I am not getting juice from the spinner post on the module
     
  6. bliz&hinikerDLR

    bliz&hinikerDLR Senior Member
    Messages: 471

    Have had a module fail that way. Pretty sure that is your problem. Cheap fix is to run both conveyor and spinner off conveyor post. Works like old gas spreaders that way.
     
  7. all ferris

    all ferris Senior Member
    Messages: 119

    Did you get this fixed? Mine failed to and it was the spreader module. They say not to "jump" the motors because it will mess up the module
     
  8. Mr.Markus

    Mr.Markus PlowSite Fanatic
    Messages: 5,169

    Always disconnect the module to jump test a motor....I've even had dealers screw this up.