1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Western Tornado Gen 2 1.8

Discussion in 'Ice Management' started by IA snoman, Mar 10, 2010.

  1. IA snoman

    IA snoman Senior Member
    from Ia
    Messages: 153

    I was wondering if anybody on here that has a new Tornado has run sand through there spreader. I have attempted to run 3 loads of straight sand through it and it doesn't move at all. I have taken it back to have it looked at and I am not getting much support.
    any body out there having similar issues.
  2. buckwheat_la

    buckwheat_la 2000 Club Member
    Messages: 2,254

    talk to mackman, he bought one of those machines recently, i believe he even posted some pics and maybe a video of it running in the equipment pics thread
  3. rpainetfd

    rpainetfd Member
    Messages: 44

    I have the Fisher model. I have run approx 20 ton of sand treated with Ice Ban through mine. The Ice Ban makes the sand heavier and stickier than straight sand. The only problem I had was if it was fully loaded, sometimes I would hit the start button and it would flash an error code of over voltage. If I held the blast button for a second it would start spreading and be fine. I must say I am very happy with this unit.
  4. Mackman

    Mackman PlowSite.com Addict
    from S.E. PA
    Messages: 1,356

    yup i got videos. Here ya go.

    <object width="480" height="385"><param name="movie" value="http://www.youtube.com/v/4cv2fzVQLRY&hl=en_US&fs=1&rel=0"></param><param name="allowFullScreen" value="true"></param><param name="allowscriptaccess" value="always"></param><embed src="http://www.youtube.com/v/4cv2fzVQLRY&hl=en_US&fs=1&rel=0" type="application/x-shockwave-flash" allowscriptaccess="always" allowfullscreen="true" width="480" height="385"></embed></object>

    <object width="480" height="385"><param name="movie" value="http://www.youtube.com/v/lMNFqwiLBT0&hl=en_US&fs=1&rel=0"></param><param name="allowFullScreen" value="true"></param><param name="allowscriptaccess" value="always"></param><embed src="http://www.youtube.com/v/lMNFqwiLBT0&hl=en_US&fs=1&rel=0" type="application/x-shockwave-flash" allowscriptaccess="always" allowfullscreen="true" width="480" height="385"></embed></object>