1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

western sno pro I

Discussion in 'Ice Management' started by timetraveler, Jan 8, 2013.

  1. timetraveler

    timetraveler Junior Member
    from 45133
    Messages: 23

    I have a western sno pro I, apparently unless otherwise informed my motor has taken a crap on me, I have done all the usual, clean terminals, checked for power turned by hand which it turns freely etc. but still no turny turn turn of the salt spreader.

    So with that I suppose I am looking for a motor for a sno pro I, new is great if its affordable, used would work if its worth it. Anyone had similar problems like this with this particular spreader. only thing I can see possibly is that when I took wires off terminals the entire terminal block turned but I was extremly careful while doing this after I let it soak for a full day in pb blaster.

    anyone have an extra motor for this or a possible fix. 513 800 3957 hillsboro ohio
     
  2. racer47

    racer47 Senior Member
    Messages: 324

    ussmileyflaglast last 1 i bought was on ebay for less than 100.00 bucks... if moters in good shape you can get brush kit for them from western dealer... i got some moter parts left,:drinkup: housing shot but brushes and armature good 740 649 8015
     
  3. T-Trim

    T-Trim Senior Member
    from NE OH
    Messages: 207

    If you have a jump box. Try connecting directly to the motor.
     
  4. timetraveler

    timetraveler Junior Member
    from 45133
    Messages: 23

    sno pro I

    Ok, T-Trim, I tried the jump box with no luck, I am to assume at this point the motor is bad correct. Honestly its been on for three years with no issue's not so much as a hint of an issue. I suppose I am luckier then most I rekon.

    Back to the used, or reasonably priced new, problem is with new, I don't know which one to purchase. I checked out ebay, yep their on there but its anyone's guess as to which one I need. the part number on mine is long since gone to better days. Any suggestions, and is this an upgrade able item. meaning can i put a slightly larger motor on there and expect better results in the spread of salt. I really dont have any issue's so i suppose exact fit would work.
     
  5. timetraveler

    timetraveler Junior Member
    from 45133
    Messages: 23

    racer we need to get together and see what we can make of this western speader motor. what's your schedule looking like. and also, whats the chances of you having a truck side meyer control harness. I am really just wanting to hook my stuff up so i understand whats there. this hoj poj mess i got is frustrating to say least.
     
  6. racer47

    racer47 Senior Member
    Messages: 324

    :mechanic:ebay item 130587922740 seller dbelectric western 8815 or fisher 9524 this is a direct replacement for the proflow 1 86.40 free shipping you cant beat that price anywhere i have some parts you can have if you want to pick up moter parts spinner shaft and disk maybe some barrings but i would just put new moter on and be done with it and store spreader under cover when not in use good luck 740 649 8015 ussmileyflag
     
  7. racer47

    racer47 Senior Member
    Messages: 324

    i dont have a wireing harness or mount i do have a slick stick control i replyed to your post looking for parts and left you a webpage and number to get what you need give me a call i will be up my schedule is fix roof in morning. pray for snow. feed woodburner. and drink beer
     
    Last edited: Jan 8, 2013
  8. timetraveler

    timetraveler Junior Member
    from 45133
    Messages: 23

    Gotta give thanks to racer 47 on here, twice ive been in a spot and the fellow's given me a hand, once on some meyer's part's and pump tear down & seal replacement. And today on some back up salt spreader part's, between his parts and time I got my sno pro I back ready.

    i've been out his way twice now, that's near chillicothe ohio, and meyer parts a plenty. if you got a meyer pump problem and your near this location I can give you his number.

    Thanks Racer 47
     
  9. T-Trim

    T-Trim Senior Member
    from NE OH
    Messages: 207

    can the brushes be replaced on your motor?
     
  10. timetraveler

    timetraveler Junior Member
    from 45133
    Messages: 23

    yeah T-trim they are replacable brushes, is that what cause's the motor to hang up when you flip the switch. I basically am having to get out and give it a jump push. after its starts to turn its fine, UNTIL i switch it back off for a period of time. Then I have to give it a nother jump push. aggervating, its working and doing its job but aggervating when it doesnt want to work as it should. I know the motor is good just not sure about the hanging up part.
     
  11. timetraveler

    timetraveler Junior Member
    from 45133
    Messages: 23

    spreader motor

    hey, whats up, so you asked me how the spreader was doing, did you get the message about when i turn it on, it wont come on unless i jump out and give it a push. after pushing it, it will work until i turn it off again then i'll have to do the same thing to get it going.

    and i went ahead and ordered the harness and switch from angilos, with the mount. only part i havent found is the back side of the mount so i can mount the switch to the shifter. i got the big part not the back

    any ideal where to find one from
     
  12. racer47

    racer47 Senior Member
    Messages: 324

    :mechanic:i got 1 you can have... also does your spreader do this all the time.. even when empty .. sound like wireing to me, wire to small bad switch bad connection ,try jumping it off battery and cables that will rule out your wireing job ..:drinkup:
     
  13. timetraveler

    timetraveler Junior Member
    from 45133
    Messages: 23

    switch is good, wiring is sound, checked the ground, actually removed ground and positive wire brushed, and re installed. it does it all the time. spreader works but if you turn it off and turn it back on it will not turn on unless you manually push the spreader wheel. if you turn spreader wheel it will start just fine.