1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

western salter only runs for 10sec, then stops

Discussion in 'Ice Management' started by ajs, Dec 24, 2012.

  1. ajs

    ajs Junior Member
    Messages: 9

    I picked up a used western salter during the summer and installed it on my truck and everthing worked. I go to use it today and it only spreads for about 10sec then stops. If i hold the stop button for a few seconds then wait a min or so. I can turn it on and it will spread again for 10 sec or so. Does any body have any tips or tricks for this, I am confused. Never had a salter before. Thanks Andy
     
  2. Raymond S.

    Raymond S. Senior Member
    Messages: 513

    Is it a tailgate salter? Could be a faulty controller or the motor pulling too much of a load. For our tailgate salters we use a toggle switch. Power to the switch, jumper fuse, power to spreader. I got tired of burning up controllers.
     
  3. REAPER

    REAPER 2000 Club Member
    from 60050
    Messages: 2,228

    If this is the Western 1000 or 2000 it sounds like the set screw at the top bearing is loose. Remove plastic cover and on the side of the bearing where the shaft comes up is a set screw. Tighten with a small allen key and you should be good to go. While you are there it is a good time to grease the top bearing as well.