1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Western Plow pump sounds but wo't raise !

Discussion in 'Western Plows Discussion' started by douglasv, Dec 11, 2008.

  1. douglasv

    douglasv Junior Member
    from Iowa
    Messages: 3

    I refilled the fluid ,didn't help ! When the check valve is out fluid sprays out when activated ! This is my first try to get a snow plow to work !:crying! The angle left and right work fine !
     
    Last edited: Dec 11, 2008
  2. Crash935

    Crash935 2000 Club Member
    Messages: 2,377

  3. douglasv

    douglasv Junior Member
    from Iowa
    Messages: 3

    THANKS Crash I think the shooting guide travels between the lift valve and the check valve ? I was going to try that in the morning ! I found it at Angelo's trouble shooting , they call it a shuttle if this is the same part you are referring to ! I plan to take out the check valve and grab the shuttle with long tweezers and clean it . Then re install it and work on getting the proper setting on the check valve !
     
  4. Crash935

    Crash935 2000 Club Member
    Messages: 2,377

    Get your check valve set and then use the flow chart in the guide.

    Trust me, if you cant find the problem using the guide then it probably isnt broke! :dizzy:
     
  5. douglasv

    douglasv Junior Member
    from Iowa
    Messages: 3

    Is that flow chart with the new check valve set? The link you gave has given some good info also !