1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Western Plow Problems

Discussion in 'Truck & Equipment Repair' started by cwlc, Aug 17, 2009.

  1. cwlc

    cwlc Junior Member
    Messages: 3

    I have a Western 7.5' strait plow that is giving me all sorts of headaches. In the spring I cleaned it up and put it away, upon putting it away I blew a hydrolic line for the right and left movements. I didnt fix it right away but when I did I put two new lines in and now when I hook it up I cant get the plow to do anything. When I turn the power on to the plow and hit the buttons all I get is a clicking noise. The motor doesnt seem to make any type of whining sounds like it is pushing any fluid. After it sat for awhile I unplugged the power cord with all of the small pins inside of it and left the two prong wire still plugged in. That afternoon, I came to my shed and found it filled with smoke. I found one of the new hydrolic lines blown. If anyone can tell me what is going on I would really appreciate it.
     
  2. no lead

    no lead PlowSite.com Addict
    Messages: 1,308

    sound like you have a bad ground at the battery. the plow is grounding through the hose more than likely.
     
  3. mnic

    mnic Junior Member
    Messages: 19

    Did you change the couplers on the hoses if the ball in the end is frozen it will plug the hose and fluid wont move through leading to blowing the hose