1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

western plow on a cj7

Discussion in 'Western Plows Discussion' started by robp, Jan 17, 2008.

  1. robp

    robp Junior Member
    Messages: 12

    newbie

    Old western plow. mark III series? has motor and hydraulics attached to front. Control consists of 2 cables and a ground. That is what i know of it. Anyway........

    Ok, got the plow connected to the jeep. Connected the hydraulic hoses. Filled up the reservoir and connected power.

    I can hear the motor but no hydraulic action up down no angle nothing.

    Do i have a bad pump? What are some simple (in layman's terms) things I can check for?

    Any help appreciated.

    Rob
     
    Last edited: Jan 17, 2008
  2. smithplowrepair

    smithplowrepair Junior Member
    Messages: 2

    Rob, before going into any disassembly of the unit, try to adjust the cable ends at the pump to make sure they are engaging the selenoids. You can remove the covers and manualy rotate the mechanical lobes inside. Caution, if you do it this way with power on the plow it could move while you are between the plow and vehicle. SAFETY FIRST!!!
     
  3. robp

    robp Junior Member
    Messages: 12

    I'll try it out

    I'll try out the cables. Thanks for the help.

    rob
     
  4. robp

    robp Junior Member
    Messages: 12

    Got the thing to go up and then.......

    prsport

    Western plow question.

    It looks like new cables will help. I opened both cable covers and could manually move the "lobes". One cable was not working.

    I got the plow to lift (a good sign) but could not get it to lower. I tried moving the "lobes" in different positions.

    So I loosened the jamb nut and released pressure on the valve to get the blade to lower.

    I need help in determining why the blade will not lower on its own???