1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Western plow No power from handle

Discussion in 'Truck & Equipment Repair' started by sctrip2, Dec 26, 2011.

  1. sctrip2

    sctrip2 Junior Member
    Messages: 7

    I have a western plow that I just put in a new pump. Everything electrical seemed to work before but now I don't seem to get anything when I push the lever to raise the blade. This is on a 97 f-250. I have power going to the solenoid. but do not get anything to the small terminal of the solenoid. So no power to the plow motor. Is the wire from from the handle a hot wire or some sort of a ground wire. I don't know what could have happened but it doesn't work now .Any suggestions ?
     
  2. muffy189

    muffy189 Senior Member
    Messages: 548

    is it a cable operated model
     
  3. sctrip2

    sctrip2 Junior Member
    Messages: 7

    Yes it is a older cable operated system. It just has the two cables for turning the blade and one wire coming from the handle mechanism. I have a new motor and new pump but now I get nothing from the handle and no voltage on the small terminal of the solenoid.
     
  4. muffy189

    muffy189 Senior Member
    Messages: 548

    check your small wire running out of the t handle or joystick which ever style you have.make sure its connected to the solenoid. which do have t hand or the joystick
     
  5. sctrip2

    sctrip2 Junior Member
    Messages: 7

    I have a joy stick style. I checked and the wire from the joystick is running to the small wire on the solenoid. Before when I pushed the joystick to raise the blade I could see the voltage drop in the truck but I get no drop now. I have tried two solenoids and still nothing. I think I may have to take the handle apart. The wire is not broke anywhere that I can see. Just weird.
     
  6. muffy189

    muffy189 Senior Member
    Messages: 548

    ok also on the joystick on the inside there is three brass tabs sometimes those dont make contact and you have to bend them a little. ive had that problem with mine before try that it may be whats wrong
     
  7. sctrip2

    sctrip2 Junior Member
    Messages: 7

    Will do. Thanks so much. I have been t a lose trying to figure this out. Ill try it tomorrow. Thanks again.