1. Welcome to PlowSite. Notice a fresh look and new features? Explore this quick video tour of updates and enhancements. It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Western plow lights

Discussion in 'Truck & Equipment Repair' started by BR54912, Dec 5, 2012.

  1. BR54912

    BR54912 Junior Member
    from WV
    Messages: 24

    I am installing a western unimount plow on a 99 dodge 2500 w cummins eng. i checked the number on the harness and i think its for a 98 or 99 dakota. I have everything working except the headlights the truck does not have drl. I have power to low beam and high beam relays and i think the relays are working they do snap. Im thinking to just unhook the plugs on the truck lights and run a seperate high and low switch to operate the plow headlights. I just need some help on what to do or maybe what to try and how to wire them that way if someone can help.
     
  2. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,683

    you can just run switches for the lights,,,but your probally closer then you think with your current setup. so your relays are clicking,,,,did you ck for all the proper pwr and gnd at the proper pins??
    try westerns website for the wiring diag
     
  3. BR54912

    BR54912 Junior Member
    from WV
    Messages: 24

    I have power to the pins for the running and turn signal lights but dont seem to have power for the high and low beams at the plug. I dont seem to have power for the black and white wires at the relays on i think its 87 that go to the plug i do have a couple of new relays just in case but havnt tried them yet. I havnt checked continuity yet from the wire on the relay to the plug but with the marker lights working and there doesnt seem to be any damage to the wiring. Thanks for the help
     
  4. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,683

    I'll start here
    Bk/og ..gnd for both relays at pins 85
    Br...pin 86
    Bk...pin 87...low beam
    Og..pin 87a...low beam
    Y....pin 30...low beam

    Gn..pin 30...high beam
    W..pin 87..high beam
    Rd...pin 87a highbeam
     
  5. BR54912

    BR54912 Junior Member
    from WV
    Messages: 24

    Sorry yes i do have a copy of the western plow schematic. the relays seem to be hooked up right according to the schematic. Headlights work on truck when 9 pin connector is not plug in to plow but when i plug in plow, truck headlights go out and the high beam indicator on dash comes on and will not switch with the switch and no plow headlights running lights are on both and those i spliced in to the truck wire. Should there be power at the 9 pin connector when the low or high beams are on i have check with a test light and dont seem to have power
     
  6. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,683

    Yea you should have pwr at that 9 pin, When you plug in 2pin that gnds out the relays and you get pwr going from 87a to 87 and that goes to the plow lights. So double ck your gnds as well
     
  7. BR54912

    BR54912 Junior Member
    from WV
    Messages: 24

    Had a chance to check the blk/org every spot seems to be grounded checked continuity. Checked continuity from wire at relay to 9 pin and both high and low are good. Plow works so i should have good grounds is that correct? Should i try replacing a relay or is that pretty much useless?
     
  8. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,683

    If ur gnds are good then ur good....just need to find out where and why your not switching to plow lights.
    When you turn on your lights. You should have pwr at pin 86...bwn wire,,pin 87a...org. and pin 30...yllo. when you plug in the plow plugs, the 2 plug gnds out the system. And the 9 pins carries the gnd back to those relays. So then they should switch from 87a..org to. 87 bk .....that goes to plow lights
     
  9. BR54912

    BR54912 Junior Member
    from WV
    Messages: 24

    I just checked the plow side i hooked to another 9 pin truck and everything works i will have to check the wires on your last post butt im running out of ideas
     
  10. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,683

    Ok. So that just narrows it dwn to the tk side. That's good then we know where the issue is
     
  11. BR54912

    BR54912 Junior Member
    from WV
    Messages: 24

    Have power at brn 86 87a org and at 30 i still dont have power to blk or wht going to 9 pin. I tried a new relay and still have the same thing. Hope you can help
     
  12. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,683

    Ok. The wht and red are the high beam relay. Along with Gn
    So it just sounds like you don't have gnd at the bk/og wire when the plow is hooked up. Is that correct??
    You said you have westerns schematic correct?
     
  13. BR54912

    BR54912 Junior Member
    from WV
    Messages: 24

    I guess it may be a grd lol im so confused right now im not sure if im up or down. The schematic im using is for hdlmp kit 9 pin, harness type c, headlamps 2b/2d 2e hb1 and drl no
     
  14. BR54912

    BR54912 Junior Member
    from WV
    Messages: 24

    If it is a grd could i run a ground to blk/org at the relays to just double check? would that work for a fix? could it be a bad spot in the blk/org near the relays and thats why everything else is working.
     
  15. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,683

    You can gnd the relays just to ck,,,but not permanent..your tk lights would never come on. Yea it could be a bad spot,,bad connectors corroded wires etc....just gotta start looking
     
  16. BR54912

    BR54912 Junior Member
    from WV
    Messages: 24

    I think i have checked everything i have continuity from the pin to the wires at the relays and from the relays over to the solenoid blk /org and i think i have checked all connections.
    I think i am at the point of just wiring in a switch? Do i just plug the headlights back in to truck wiring and then do i need to add the on off on switch and run new wires to the plow harness plug? I'm not sure exactly how to do this but if you could help i could use it.
     
  17. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,683

  18. BR54912

    BR54912 Junior Member
    from WV
    Messages: 24

    Ok i took a test light and with the plow not hooked up i clipped the pos on bat and light to the blk/org at the relays and the light came on and the relays clicked. And not sure if it makes a diff. but my setup is like page 61.
     
  19. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,683

    You gotta have the bk/og gnded. Like plow hooked up for the relays to work right your getting close. Now gnd the relays,,turn on your lights and prob for pwr and see what you have
     
  20. BR54912

    BR54912 Junior Member
    from WV
    Messages: 24

    Ok plow hooked up Plow headlights do not work high beam indicator is on in truck and cant switch off no power at 87 black or white power is at 30 and 87a on both relays. Running lights are on at the plow