1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Western Plow Lights (Relay) Problems

Discussion in 'Ram Trucks' started by PasionitGrandpa, Dec 28, 2010.

  1. PasionitGrandpa

    PasionitGrandpa Junior Member
    Messages: 24

    Hi I am a newbie to this site and what a site, vast amount of knowledge here and I am glad I found this site.

    I have a 99 Dodge 2500 4x4 that I just bought 2 weeks ago, in my 40 plus years this is my first Dodge but anyway, I have been pulling my hair out what little is left the past 2 weeks trying to figure out this wiring problem.

    I have downloaded every manual off the western site and still cannot figure this out. I have the 9 pin 5 relay setup and have checked the schematic time after time and looked at the wiring and everything is wired correctly to western's wiring schematic, I have double and tripled checked it each day and cannot figure where the problem is.

    With the truck shut off and the lights off, my plow lights are on constantly, when I turn the lights to parking lights everything is fine, when I turn my headlights on my plow lights come on and my headlights stay on, it seems to me I have a constant power source to a relay when all my lights are off and the plow lights stay on but what could it be??

    Also I thought with this relay system when you turn on the plow lights your headlights are suppose to go out and vise versa right? Any help would be much appreciated..

    I am going bald....LOL

    Early Happy New Year!
    Regards,
    Kev
     
  2. ProSeasons

    ProSeasons Senior Member
    Messages: 624

    When you bought the Dodge, did it come with the Western Plow?
     
  3. PasionitGrandpa

    PasionitGrandpa Junior Member
    Messages: 24

    Thanks for getting back to me! Yes it did, it was bought like that with the unimount already on the truck. I went to Advance and bought 5 5 prong relays and put them in and nothing works, so I cleaned up the old western relays and installed 3 and now the plow lights don't stay on all the time now, and when I put on the parking lights everything is good there and when I turn on the headlights the plow lights and the headlights are still on together but when I put the brights on my headlights go out and the plow lights go to high beams. Do I need western relays? I am into this project almost 3 weeks now and still I am clueless.

    Kev
     
  4. b&b landscapes

    b&b landscapes Member
    Messages: 74

    i just bought my 99 2500 and installed a meyer plow and had the same problem.

    The lighting system on these trucks are constant power and lights are activated by ground, unlike the plow lights and whoever had the truck didnt want to mess with it.

    I had to buy a three way toggle switch and wire the plow lights seperate from the headlights, note this is only the headlights, you can wire the parking and turn signals to work with the western harness.

    The plow prob didnt come on the truck and they never bought the proper harness, as thats what i did, i took the plow i have off a 94 chevy, bought the right truck side mount and never gave the wiring harness a thought until i tries wirirng it up. had same prob.

    WARNING - this will or may melt some wires so disconnect the headlight wiring of the plow immediately and buy a 3 way toggle and wire it up seperately.

    Very easy to do, three way toggle is for high - off - low


    Iff you need more help you can feel free to call me 513-418-8381 name is Derrick and i can walk you thru wiring it up
     
  5. DAFFMOBILEWASH

    DAFFMOBILEWASH PlowSite.com Addict
    Messages: 1,598

    The lighting systems from the plow manufactures are way too complicated with needless relays junctions and junk. They made them look great for the day of delivery but in time watch out.

    I am with B&B on this one ... Pull the Western stuff and install your own. Make sure you use high quality switches and resetable fuse. (the ones the power window motors use)
     
  6. PasionitGrandpa

    PasionitGrandpa Junior Member
    Messages: 24

    Thanks for the reply's guys. Quick update: I cleaned the 3 western plow relays with baking soda and water and was able to finally see the numbers on the relay. What I did was change out the vehicle low beam relay and the plow low beam relay and got rid of those cheapies I bought and now when you put the headlights on (low beams) the plow lights come on and the headlights are off.

    I guess I need to buy 2 more relays for the high beams. Or I can do what b&b suggested and I think I will, I already bought a on-off-on 40 amp toggle switch, can you give me a hint on how to wire this up b&b?

    [​IMG]

    If you would be so kind to tell me how to ground it and what to do with those wires.

    Happy New Year!!
    Kev
     
  7. shep28

    shep28 Member
    Messages: 84

    Did you ever figure out your lighting issue. I have the same problem.
    With the truck shut off and the lights off, my plow lights are on constantly, when I turn the lights to parking lights everything is fine, when I turn my headlights on my plow lights come on and my headlights stay on
     
  8. Philbilly2

    Philbilly2 2000 Club Member
    Messages: 2,632

    Seriously????? The guy has the correct harness and you tell him to cut it apart and hillbilly in a switch? :jester:

    It is possible to change western harnesses from Positive Common to Negitive Common depeneding on the year and make of the truck.

    shep28. You most likley have a relay that is seeing 12v when it should not be. Is this a problem that you have always had, or is this a new problem?
     
  9. shep28

    shep28 Member
    Messages: 84

    Truck sat for the entire summer. When I started it up I noticed the plow low beams stayed on when the truck was off, but not the plow parking lights. I also heard a buzzing sound coming from a relay. I replaced the relays and there is now no buzzing, but the lights still stay on and the truck lights do not switch off when the plow harness is connected.
     
  10. kenny96dodge

    kenny96dodge Junior Member
    Messages: 23

    i have a 96 dodge 1500, it has a uni mount western plow on it. when i got the truck w/plow on it a few months ago my truck lights and plow lights worked, except i only had high beams on the plow, i had low beam on both plow and truck, i went threw and figured out what wiring type my set up was and printed off the schematic and rewired the whole system replacing most of the wiring and all 4 relays and connectors. now that i have done that i have high beam and low beam on the truck and nothing for lights on the plow but turn signals. i checked all my lights and they work on the plow but its not gettting power trnsfered from the 2 truck relays to the 2 plow relays, what should i do, im lost for the most part when it comes to trying to figure out why the power isnt being relays to the relays and turning the plow lights on, does any one have some stuff i could check or do to fix this problem?
     
  11. snowpro44

    snowpro44 Member
    Messages: 45

    sounds like you have a wire crossed somewhere..when plow is hooked up..the plow lights r on..disconected truck light on..problems is in one of the relays..you are back feeding through one of the four relays..not in the 9 pincheck.. all relays one or both is stuck on..
     
    Last edited: Nov 17, 2013
  12. basher

    basher PlowSite Fanatic
    from 19707
    Messages: 8,992

    No the easy way to do it would have been flip the plug configuration.:nod:
     
  13. basher

    basher PlowSite Fanatic
    from 19707
    Messages: 8,992

    Have you checked the grill plugs? They are infamous for rotting internally.
     
  14. snowpro44

    snowpro44 Member
    Messages: 45

    could be in the headlight switch in the truck..
     
  15. kenny96dodge

    kenny96dodge Junior Member
    Messages: 23

    Yes I checked them and cleaned them, I messed around with it some more last and If I take the red power wire and touch It to the connection on the relay that goes to the high or low beams on the plow side it lights the lights up but it seems like relays are not activating to transfer power threw them to turn the plow lights on, I was looking at the diagram on a posting above and it shows the tan wires hooked to 85 on the relay and on the schematic I have from western says they go on 86 so I don't know if I should switch the wires around to the diagram above or not
     
    Last edited: Nov 17, 2013
  16. kenny96dodge

    kenny96dodge Junior Member
    Messages: 23

     
  17. snowpro44

    snowpro44 Member
    Messages: 45

    ok..that explain alot!!you may have melted wires somewhere else??..check harness threw the firewall...make sure all your grounds r clean!!...
     
  18. kenny96dodge

    kenny96dodge Junior Member
    Messages: 23

    Ok I will check the wiring but I'm thinking it's a problem with how the relay are wired up, like India I'm not much in wiring in a vehicle so I'm gonna exhaust every possibility on fixing this before I have to take I and have it looks at by a vehicle electrical guy here where I live
     
  19. snowpro44

    snowpro44 Member
    Messages: 45

    good luck!!wiring sucks
     
  20. kenny96dodge

    kenny96dodge Junior Member
    Messages: 23

    Yea I know I hate wiring on a vehicle but I need tho figured out so I can he the plow back on my truck