1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Western Plow Light Question Help

Discussion in 'Truck & Equipment Repair' started by mpro1, Jan 14, 2009.

  1. mpro1

    mpro1 Junior Member
    from 11746
    Messages: 6

    Hello,

    I recently installed the wiring and western uni-mount snow plow on my 2002 chevy silverado 1500 series pick-up........the plow controls all work fine and so do the headlights on the truck......The plow lights are not working.....exept right and left turn.......can anyone help with trouble shooting? I have checked and double checked the relays ect....I don't think that the relays are energizing...What is the best way to test??

    Thanks
     
  2. Crash935

    Crash935 2000 Club Member
    Messages: 2,377

    Did you or are you sure you taped into the marker light wire on the truck? Need to gete the test light out and findwhere the brown wire from the marker lights comes to the relays and make sure there is power there with the marker lights on.
     
  3. got-h2o

    got-h2o 2000 Club Member
    Messages: 2,439

    That won't affect the plow headlights. I'm wondering if he has the wrong harness. Are the brights working? It could be a broken pin in the plow side plug.
     
  4. mpro1

    mpro1 Junior Member
    from 11746
    Messages: 6

    Thanks for the replies........By the marker lamps are you referring to the park lamps?..............I have the schematic 1999-2002 9 pin type hb-3 hb-4, and followed to the tee......maybe I'll have to check all the tap in points again?? I wonder if i need these drl anyway? I have jumped out the plow side lights and they all work, I checked for continuity from the front connector all is good.....Basically when i turn on the truck lights they work as normal.. lows, highs ect......but when I plug the front connect in they stay on, and don't switch the relays to the plow side.....the signals all work because they are not going into relays......I'm stumped for now??
     
    Last edited: Jan 15, 2009
  5. elite1msmith

    elite1msmith 2000 Club Member
    from chicago
    Messages: 2,762

    by pass the relay your self

    disconnect it, then jumper from terminal 30 to 87a with yoru head light switch on... if so , then your truck head lights should come on

    then jump from 30 to 87 and your plow headlights come on


    sounds like your marker light wire wich runs the relays isnt hooked up
     
  6. Crash935

    Crash935 2000 Club Member
    Messages: 2,377

    Really, im pretty sure that the power from the marker lights powers the relays. Well on his truck it powers the truck side low and high beam relays but with no power to them your kind of SOL.
     
  7. no lead

    no lead PlowSite.com Addict
    Messages: 1,308

    double check the brown wire. it must be hot for the relays to power up.
     
  8. Crash935

    Crash935 2000 Club Member
    Messages: 2,377

    Marker/park feed is what i keep coming back to.

    a few other possibilites,
    red wire for the fuses not on constant hot from battery
    Tan jumper with diode in wrong sequence

    Just for giggles, find pin 5 in the truck side grill connector and jump from that to the ground on the battery, did you hear the relays click and did the truck lights go off?
     
  9. got-h2o

    got-h2o 2000 Club Member
    Messages: 2,439

    I stand corrected
     
  10. no lead

    no lead PlowSite.com Addict
    Messages: 1,308

    the gm multi relay can be tricky at best.:realmad:
     
  11. Crash935

    Crash935 2000 Club Member
    Messages: 2,377

    Dont listen to him, he always walked away prsport scratching his head and left me to figure it out!!!!:nod:
     
  12. got-h2o

    got-h2o 2000 Club Member
    Messages: 2,439

    Funny too b/c I can now nearly wire the GM 6 relays with my eyes closed, just never studied a diagram enough to realize that's what powered them up. Sure as hell makes sense now!
     
  13. mpro1

    mpro1 Junior Member
    from 11746
    Messages: 6

    Thanks for the help........it turned out that there was somthing wrong with the tan jumper wires....so i made up a new one and worked great.......
     
  14. Crash935

    Crash935 2000 Club Member
    Messages: 2,377

    Glad you got it fixed.

    And thanks for letting us know what you found!
     
  15. ivans snow plow

    ivans snow plow Junior Member
    from chicago
    Messages: 24

    western snow plow lights not working

    Hi all, I have the same problem with my plow lights. All the lights work fine on the truck side but hen I connect the plow the lights wont switch over? I bought brand new 9 pin repair connectors from truck side and plow side and still not switching over by the way turn signals working fine. I also bypassed the connectors to make sure, and still not switching over, it was working fine last couple weeks, could that be low beam relays????

    thanks for your help