1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Western plow headlight and joy stick problems

Discussion in 'Western Plows Discussion' started by Jpslandscaping, Dec 5, 2013.

  1. Jpslandscaping

    Jpslandscaping Junior Member
    Messages: 2

    I just bought a western unimount plow that was on a 1994 Chevy 1500 that I took off and put it on a 1991 Chevy 1500. I had to buy a head light harness because the truck I put it on had hb3-hb4 headlights. I thought I hooked every thing up but when I go to switch the light on for the joystick no light comes on and when the 9 pin is plugged in the marker lights come on the plow but head lights don't, they just dim on the truck. The red wire off the joystick is tied into a inline fuse that is hooked up to the radio fuse. I'm stomped now. Any help please. Thank jimmy

    Jps landscaping
     
  2. OneBadDodge06

    OneBadDodge06 Senior Member
    from Iowa
    Messages: 735

    Check to make sure your relays are hooked in right. You can also check Western's website for the exact part number if you have the right headlight harnesses. You should also hear them click over when the plow is plugged in.

    As for your joystick, check your grounds really good. The dealer can also bench test the cabcommand to verify its working. I would of used a accessory port in the fuse box on the driver's side dash. May or may not be enough juice running off a radio....just a thought.
     
  3. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,972

    Also make sure the gnds are good. The main plow gnd and the gnd at the solenoid (2 wires branching off one of the small pins) one of those goes back and gnds the clicker
     
  4. Jpslandscaping

    Jpslandscaping Junior Member
    Messages: 2

    Thanks everyone. Got it working. Me and my buddie put a jumper wire on the solenoid because I read the directions wrong. Took it off and every thing works great now.