1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Western Plow Controller Question

Discussion in 'Truck & Equipment Repair' started by RathTR, Jan 19, 2016.

  1. RathTR

    RathTR Junior Member
    Messages: 16

    I was walking by my truck last night and noticed that the light on the display of my controller is on all the time that the plow is connected. Even with the truck off. Without the plow connected, it's off. Is this normal? I have an '08 Sierra with an Ultra Mount.
     
  2. Philbilly2

    Philbilly2 2000 Club Member
    Messages: 2,633

    You need to move the red wire under your dash to a key switched source.

    Right now it is on a hot all the time leg.
     
  3. RathTR

    RathTR Junior Member
    Messages: 16

    Controller Question

    It is on a keyed power source. When the plow is not connected, it functions normally. When plow is connected the display light is on solid.
     
  4. Philbilly2

    Philbilly2 2000 Club Member
    Messages: 2,633


    First thing we are speaking hand held controller not joystick here right?

    Are you speaking of the backlight or the red light in the corner by the power button?
     
  5. RathTR

    RathTR Junior Member
    Messages: 16

    Yes, handheld controller, and yes the backlight.
     
  6. Philbilly2

    Philbilly2 2000 Club Member
    Messages: 2,633

    Can you do me a favor and go out to your truck and try to turn the power on to the handheld without putting a key in the ignition and see if the power comes on and the plow operates?

    The back light being lit is what should happen if the plow is connected and 12v+ is present at the controller.
     
  7. RathTR

    RathTR Junior Member
    Messages: 16

    OK... I'll have to do that after work tonight. I'll let you know this evening. Thanks for the help.
     
  8. RathTR

    RathTR Junior Member
    Messages: 16

    OK.... Don't I feel like a knucklehead now. I did test the circuit with a test light last night and got no continuity. Apparently I wasn't making good contact with the pin because guess what?????????..... Yeah, you called it...... I was connected to a constant 12 volt source. That's what I get for not being more careful. Thanks for the tip. I really appreciate it.
    Todd
     
  9. Philbilly2

    Philbilly2 2000 Club Member
    Messages: 2,633

    No sweat bud. Glad you got it figured out.
     
  10. MikeA5150

    MikeA5150 Member
    Messages: 57

    I have the exact same thing going on. Where did you move the red wire to in the fuse box ?
     
  11. Philbilly2

    Philbilly2 2000 Club Member
    Messages: 2,633

    Try the windshield wiper fuse
     
  12. MikeA5150

    MikeA5150 Member
    Messages: 57

    I will, thanks.
     
  13. MikeA5150

    MikeA5150 Member
    Messages: 57

    It worked thx. Stupid question......will the controller light up at all if plow is disconnected ?
     
  14. cubicinches

    cubicinches PlowSite.com Addict
    Messages: 1,412

    No........
     
  15. MikeA5150

    MikeA5150 Member
    Messages: 57

    Gotcha, thx.