1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Western plow blowing fuses to the lights

Discussion in 'Truck & Equipment Repair' started by 88chevy, Dec 14, 2008.

  1. 88chevy

    88chevy Junior Member
    Messages: 5

    I have a 7.6 western works great but for some reason the plow lights will work for a half hour or so the blow the fuse. when this happen i lose my plow lights my dash lights and tail lights. but the head lights on the truck come on. is it my relays.or where should i start
  2. Crash935

    Crash935 2000 Club Member
    Messages: 2,377

    Pull the lens off the plow marker turn lights and check for corrosion in the sockets for the park/turn bulbs or a broken wire at the sockets.
  3. 88chevy

    88chevy Junior Member
    Messages: 5

    fuse blows

    i looked at the sockets and they look brand new and no cut or loose wires that i can find. any other ideas out there
  4. no lead

    no lead PlowSite.com Addict
    Messages: 1,308

    which fuse does it blow? the fuse in the fusebox or the inline fuse in the harness? if in the fuse box, turn the fuse tap to the other side of the fuse.
  5. ajordan193

    ajordan193 Senior Member
    from WNY
    Messages: 224

    I'm having the same problem with my Uni-Mount. Its blowing the fuse for the parking, gauge cluster and other lights 15 amp. any thoughts?
    Last edited: Dec 21, 2008
  6. no lead

    no lead PlowSite.com Addict
    Messages: 1,308

    bad connection somewhere. look at your plow wiring carefully. driver side turn signal is were marker and turn are hooked up. look for bare wire touching somewhere.