1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Western Plow acting up! The blade wont stay up

Discussion in 'Truck & Equipment Repair' started by jo2fst4u, Oct 19, 2010.

  1. jo2fst4u

    jo2fst4u Member
    Messages: 98

    I was doing some work on the Old Plow truck hooked up the Plow And it will go up but wont stay also when i move the Stick to the left the plow goes up real slow. I am lost as to what to check on it.

    It's an 1987 F250 western 7.6 pro relay setup
     
  2. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    Likely the S2 valve partially stuck open. S2 is the one on the top left of the three valves, should have a light green wire on the coil. Remove, inspect, clean and stroke the internal spool with a small screwdriver. If it's free re-install and try again. If it sticks again replace it.
     
  3. jo2fst4u

    jo2fst4u Member
    Messages: 98

    Tested S1 S2 S3 found S1 and S3 were sticking. cleaned them up worked for a min they they are messing up again.I am thinking i need to flush my whole system Pulled the fill plug and there is allot of dirt at the fill tube i don't want to touch as it will go into the pump.


    Plow will raise and will come down slow wont hold up. also when moving the Joystick left plow sometimes goes up sometimes work as it should but moves slow
     
  4. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    A good thorough flush certainly wouldn't be out of order. Keep an eye out for anything specific in the fluid as you're servicing it such as small bits of mushy black material or a large amount of black silt which indicates packing deterioration in one or more of the rams.
     
  5. jo2fst4u

    jo2fst4u Member
    Messages: 98

    Thanks for the Help
     
  6. jo2fst4u

    jo2fst4u Member
    Messages: 98

    Well i am still lost as to why the Blade wont stay up. All the valves are working bench tested each one. tested all the coils. Ran new grounds, Replaced the truck and plow side plugs. Somtimes when your in the truck and try and move blade left it will go right...Wait a min then it will go left. I am going to order new valves today
     
  7. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    That's a problem with the S3, either it isn't getting the signal every time or the valve itself is sticking. Before installing any new valves clean the system out. No point in running fresh valves in a dirty system.

    Also be sure to check the ground jumper lead on the coils too. Make sure each one is clean and snug on the coil terminals and that the other end has a good connection.
     
  8. jo2fst4u

    jo2fst4u Member
    Messages: 98

    cleaned the pump,filled up,tested each valves all 3 seem to work, checked the control,got volt meter out everything seem to work like it should. Plow goes up great. goes right ok no left movement when i call for left it does nothing pumps/motor runs.

    I am going to remove valve block and tear it apart clean replace the poppets and s1 s2 s3