1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

western mvp v plow problems need help

Discussion in 'Western Plows Discussion' started by sweetk30, Nov 27, 2008.

  1. sweetk30

    sweetk30 PlowSite.com Addict
    Messages: 1,588

    my buddy has a 99 f250 gas with vplow and fishstick style controler.

    simptoms : rwing no out to scoop function.
    : plow down goes down. but when button relesed plow comes back up.
    : to keep plow down have to hold button for down.

    he whent and purchased a new controler from dealer. ( before he asked me for help) . this didnt fix the problem. he said he then lost even more functions with new controler.

    i am going to check the truck and plow side plugs/pins for any signs of junk/green crap/or broken pins. then i will check the iso moduel for the same.

    if you have any other info to help this would be great thanks guys keep up the good work.
     
  2. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    The Iso module won't disturb the plow functions sweet..as the actual commands do not go through the module.

    Sure sounds like a short/broken wires in the harness, or corrosion in the grill connectors as you definitely have a few functions working against each other. Time to go digging. :waving:
     
  3. sweetk30

    sweetk30 PlowSite.com Addict
    Messages: 1,588

    o.k. then iso only does lights then?

    and if i need repair plugs would you happen to have the part#s on them?
     
  4. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    As far as controller functions go, the Iso module only supplies power to the controller...the actual command functions from the controller to the plow do not go through it.

    If you need it, the truck side repair harness p/n is: 27067

    If it needs it on the plow side as well, you want to swap the entire 7 pin control harness on the plow side, p/n 26358.
     
  5. sweetk30

    sweetk30 PlowSite.com Addict
    Messages: 1,588

    cool thanks amn. will check and get back to you.
     
  6. sweetk30

    sweetk30 PlowSite.com Addict
    Messages: 1,588

    well got to see the setup today my self.

    its a 99 plow on a p9 truck and it has the old first gen style controler with 4 tryangles and then a button top left to turn on wing only functions. it has the round black plug to the dash mount.

    when it was there today it would do stuff all by its self and the pump would still run sometimes by its self. so i cleaned the quick plug out of any junk and build up with brake cleaner and then compressed air . put it together again and seemed to be fine but then started acting up again and diffrent things were going wrong now.

    he said when the unit is first used it does this but when all warmed up and working it realy dosnt do it. so before he drives 1hr each way to the only dealer that has them in stock and on saturday and drops 200-230 bucks with sales tax on plugs he wanted me to be sure that would fix it.

    hope this helps diagnose the problem better.
     
  7. sweetk30

    sweetk30 PlowSite.com Addict
    Messages: 1,588

    well used brake cleaner on plugs and then blew them out with compressed air. re dielectric greased them. and last updated the old style controler and bam all is working 100% so far. will keep you up to date if anymore problems.