1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Western moves slow to the left

Discussion in 'Truck & Equipment Repair' started by jo2fst4u, Oct 29, 2010.

  1. jo2fst4u

    jo2fst4u Member
    Messages: 98

    I have uni mount western, I just flushed the system, replaced all 3 valves, replace the grounds. replaced the plugs. The plow is now working. But is slow moving to the left.....any ideas?


    Thanks!
     
  2. GBD

    GBD Junior Member
    from Ohio
    Messages: 21

    Is it cable opporated?
     
  3. LON

    LON Senior Member
    Messages: 749

    Pilot operated check valve.
     
  4. jo2fst4u

    jo2fst4u Member
    Messages: 98

    No

    I was told to check the popet valve in the front of the valve block
     
  5. GBD

    GBD Junior Member
    from Ohio
    Messages: 21

    Thats what I would try. You can search for a manual for the model of pump that you have and then you should be able to adjust from there. The manual will show you where all of the adjustments for the valves are and such
     
  6. blue sky guy

    blue sky guy Junior Member
    Messages: 26

    Could be air in the hyraulic line?? Most likely.
     
  7. blue sky guy

    blue sky guy Junior Member
    Messages: 26

    Hydraulic line. Sometimes that can slow a plow down.
     
  8. tecate1987

    tecate1987 Junior Member
    from pa
    Messages: 29

    My old plow did this, It ended up being the quick connect was bad.