1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Western isarmatic mark IIIa issues

Discussion in 'Western Plows Discussion' started by 20007.3stroker, Dec 9, 2010.

  1. 20007.3stroker

    20007.3stroker Junior Member
    Messages: 4

    well im hopeful that the guys on here can help me out. We have a Western isarmatic mark IIIa that can go up with assistance, but wont stay up over periods of time. It also wont stay turned either way. im thinking its either valves or pump but dont want to go dropping money on something that aint wrong.

    Thanks in advance to anyone that can help.
     
  2. twinman326

    twinman326 PlowSite.com Addict
    Messages: 1,683

    Last edited: Dec 9, 2010
  3. lukynskywyrd

    lukynskywyrd Member
    from wisc.
    Messages: 54

    check the packing as well....

    you could be loosing pressure through them
     
  4. 20007.3stroker

    20007.3stroker Junior Member
    Messages: 4

    ok got a little stuff to do before i can do that but ill try that first. i know my dad, who is the one that originally had it mounted on his old truck changed the fliuld in the lift unit but i dont think he did the whole procedure. i gotta get it mounted onto my truck yet, but if i could get more of a list of things that could cause this and ways to test them, but i dont have access to a pressure gauge so you all know.
     
  5. 20007.3stroker

    20007.3stroker Junior Member
    Messages: 4

    ok im gonna show my noobness here what is the packing.

    on edit looked at the service manual break down that i downloaded and im assuming you mean to check for leaks. also to other things i notice looking at the manuals i downloaded im gonna check the adjustment on the cushion valves. and any clue on how to free the lift valve adjustment as its stuck
     
    Last edited: Dec 9, 2010
  6. twinman326

    twinman326 PlowSite.com Addict
    Messages: 1,683

    I check the fluid first..there might be moisture inside the housing. Moisture and fluid don't mix...
     
  7. 20007.3stroker

    20007.3stroker Junior Member
    Messages: 4

    Ya I'm gonna do the fluid first, just gathering a little troubleshooting if that don't cure it
     
  8. twinman326

    twinman326 PlowSite.com Addict
    Messages: 1,683

    Lift valve being stuck, that you might have to give it a "little" heat. Not a lot, just a little..let it cool, then try.Or use PB blaster and see what happens..